Bug 104958 - NULL pointer dereference in Severn
NULL pointer dereference in Severn
Status: CLOSED DUPLICATE of bug 104922
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-23 17:30 EDT by Mike McLean
Modified: 2007-04-18 12:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2003-09-23 17:30:57 EDT
* Severn-0.93.2
* seems to be only smp machines
* kernel-smp-2.4.22-1.2061.nptl

I'm seeing several smp machines die at various places with only the message
"Unable to handle kernel NULL pointer dereference"
Comment 1 Mike McLean 2003-09-23 17:44:34 EDT
I got the following peculiar serial log from one machine as it died.  It appears
to contain several overlapping kernel error messages including a NULL
dereference and a kernel BUG.

Unngab rlee qutoes hta--nd--<1->--ke--ab--l-e [ tocu tha hg erneeq ]e
--ue-r--na--gi---<-4->
 at kverinretula lB UGa dadtr escso mm0i0ta7.dce:f7462
!
 pUrinnatbileng  teo ihpa:
ndle00 ak7erdneef6l
 NU*LpLd peo i=n 1t3e0r bd9e06r7e
fere*pntcee =< 4>0 0a0t00 0v0ir0t
ual address 00000282
 printing eip:
c029223c
*pde = 00000000
Comment 2 Mike McLean 2003-09-23 23:59:14 EDT
whee, it's like a word find.

I've managed to disentangle the following strings from the mess above.

----------[ cut here ]------------
kernel BUG at commit.c:742!      

Unable to handle kernel NULL pointer dereference at virtual address 00000282
 printing eip:
c029223c
*pde = 00000000



Some of it appears to be corrupted.  Looks like there might have been a page
fault too.

Unable to handle (garbage)
 printing eip:
00a7def6
*pde = 130b9067
*pte = 00000000



Comment 3 Dave Jones 2003-09-28 21:06:20 EDT

*** This bug has been marked as a duplicate of 104922 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:58:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.