Bug 1049276 - mod_cluster-manager may break up aliases from a single VirtualHost, causing a messy page
Summary: mod_cluster-manager may break up aliases from a single VirtualHost, causing a...
Keywords:
Status: CLOSED EOL
Alias: None
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: mod_cluster
Version: 2.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER02
: 2.1.0
Assignee: Weinan Li
QA Contact: Michal Karm Babacek
URL:
Whiteboard:
Depends On: 980246
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-07 10:27 UTC by Jean-frederic Clere
Modified: 2019-06-13 12:09 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously in JBoss Enterprise Web Server, when displaying the individual virtual hosts for a node, mod_cluster-manager displayed a page filled with aliases from a single virtual host interspersed with multiple other instances of the virtual host and its contexts. The result is unclear and can cause confusion for users. This problem occurs with concurrent start ups when JBoss has multiple applications bound to virtual servers that are deployed and enabled at the same time. This is fixed in JBoss Enterprise Web Server 2.1 and virtual hosts are always displayed correctly (and only once) on the manager page with all the relevant aliases included in the single entry. This is fixed in JBoss Enterprise Web Server 2.1 and virtual hosts are always displayed correctly (and only once) on the manager page with all the relevant aliases included in the single entry.
Clone Of: 980246
Environment:
Last Closed: 2019-06-13 12:09:55 UTC
Type: Bug


Attachments (Terms of Use)

Comment 1 Weinan Li 2014-06-10 09:53:57 UTC
Jean-Frederic, which version of mod_cluster fix this problem?

Comment 2 Jean-frederic Clere 2014-06-10 10:10:40 UTC
1.2.5.Final according to the mod_cluster JIRA.

Comment 3 Michal Karm Babacek 2014-06-18 02:58:50 UTC
This is an old issue, (fixed in m_c 1.2.5, we have 1.2.8 in ER2)
and I haven't seen it since. I can't reproduce it with EWS 2.1.0.ER2, switching to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.