This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 980246 - mod_cluster-manager may break up aliases from a single VirtualHost, causing a messy page
mod_cluster-manager may break up aliases from a single VirtualHost, causing a...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: mod_cluster (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: EAP 6.2.0
Assigned To: Jean-frederic Clere
Michal Karm Babacek
:
Depends On:
Blocks: 1049276
  Show dependency treegraph
 
Reported: 2013-07-01 16:38 EDT by Aaron Ogburn
Modified: 2014-08-07 08:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In preavious releases of JBoss EAP, it was reported that when deploying multiple applications, each with a unique virtual-server and each virtual-server with multiple aliases, the mod_cluster_manager could incorrectly display the same Virtual Host multiple time (once for each alias). This issue has been resolved and now all Virtual Hosts are displayed only once on the manager page together with all aliases as expected.
Story Points: ---
Clone Of:
: 1049276 (view as bug list)
Environment:
Last Closed: 2014-08-07 08:13:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Ogburn 2013-07-01 16:38:59 EDT
Description of problem:

Now that we properly show all the individual virtual hosts for a node, mod_cluster-manager may display a messy page with the aliases from a single Virtual Host broken up with multiple instances of the Virtual Host and its contexts. This can occur with our concurrent start ups now when JBoss has multiple applications bound to virtual servers that are deploying and enabling at once.


Version-Release number of selected component (if applicable):

1.2.4.FINAL


How reproducible:


Steps to Reproduce:
1. Deploy multiple applications on 6.1.0, each with a unique virtual-server
2. Give each virtual-server multiple aliases
3. Check the mod_cluster-manager page for multiple occurrences of a single Virtual Host

Actual results:

A single Virtual Host may be written out to the manager page multiple times with its aliases divided across each one.


Expected results:

A Virtual Host is always written out once to the manager page with all aliases together.


Additional info:

mod_cluster project bug: https://issues.jboss.org/browse/MODCLUSTER-347
Comment 8 Scott Mumford 2013-11-20 16:47:44 EST
Reworded Doc Text field slightly and marking for inclusion in the 6.2 Release Notes.
Comment 9 Jean-frederic Clere 2013-12-17 02:36:44 EST
It is already fixed.
Comment 10 Michal Karm Babacek 2014-07-01 10:03:12 EDT
...ON_QA
Comment 11 Michal Karm Babacek 2014-07-01 10:04:06 EDT
This is an old issue, (fixed in m_c 1.2.5, we have 1.2.9 in ER7)
and I haven't seen it since. I can't reproduce it with EAP 6.3.0.ER7, switching to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.