Bug 1050033 - [GSS] (6.2.x) WAIT_FOR_BEFORE_START does not work for / context applications
Summary: [GSS] (6.2.x) WAIT_FOR_BEFORE_START does not work for / context applications
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: CR1
: EAP 6.2.1
Assignee: Aaron Ogburn
QA Contact: Radim Hatlapatka
Russell Dickenson
URL:
Whiteboard:
Depends On: 1050204
Blocks: eap62-cp01-blockers
TreeView+ depends on / blocked
 
Reported: 2014-01-08 16:19 UTC by Aaron Ogburn
Modified: 2018-12-06 15:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A bug in the web connector service resulted in `WAIT_FOR_BEFORE_START` not working when deploying `/` context applications. If `WAIT_FOR_BEFORE_START` was to `/` and a `/` application is deployed, the connectors would never start. This issue has been fixed in this release of JBoss EAP 6. When setting `WAIT_FOR_BEFORE_START` to `/` and deploying a `/` context application, the connectors now start successfully.
Clone Of:
: 1050204 (view as bug list)
Environment:
Last Closed: 2014-02-24 20:14:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Aaron Ogburn 2014-01-08 16:19:57 UTC
Description of problem:

WAIT_FOR_BEFORE_START does not work for / context applications.  If you set WAIT_FOR_BEFORE_START to / and deploy a / application, the connectors never start.


Version-Release number of selected component (if applicable):

EAP 6.2.0


How reproducible:

Always


Steps to Reproduce:
1. ./standalone.sh -Dorg.apache.catalina.connector.WAIT_FOR_BEFORE_START=/
2. Deploy a / context
3. Check and see that the connectors never started as expected after / was deployed

Actual results:

Connectors never start with WAIT_FOR_BEFORE_START=/

Expected results:

Connectors start with WAIT_FOR_BEFORE_START=/ when / context app is deployed

Additional info:

It gets the newly started context through context.getPath().  When deployed to /, context.getPath() is returning "" so that doesn't match the "/" value specified on WAIT_BEFORE_START and so the condition is never satisfied.  WAIT_BEFORE_START can't be set to "" to get a matching value there since only values containing "/" are effectively used.

Comment 1 Aaron Ogburn 2014-01-08 20:18:45 UTC
PR:

https://github.com/jbossas/jboss-eap/pull/762

Comment 3 Aaron Ogburn 2014-01-08 22:41:29 UTC
Correct 6.x PR:

https://github.com/jbossas/jboss-eap/pull/768

Comment 4 Scott Mumford 2014-01-20 05:45:09 UTC
Marking for inclusion in 6.2.1 release notes documentation.

Comment 6 Radim Hatlapatka 2014-01-27 15:25:22 UTC
Verified in 6.2.1.CP.CR1-patch


Note You need to log in before you can comment on or make changes to this bug.