Bug 1050204 - WAIT_FOR_BEFORE_START does not work for / context applications
Summary: WAIT_FOR_BEFORE_START does not work for / context applications
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR0
: EAP 6.3.0
Assignee: Aaron Ogburn
QA Contact: Radim Hatlapatka
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1050033 1115117
TreeView+ depends on / blocked
 
Reported: 2014-01-08 20:38 UTC by Aaron Ogburn
Modified: 2018-12-04 16:52 UTC (History)
3 users (show)

(edit)
In previous versions of JBoss EAP the `WAIT_FOR_BEFORE_START` property did not work for root context applications. If a user set `WAIT_FOR_BEFORE_START` to / and deployed a root application, the connectors did not start as expected.

This has been corrected in this release and now when setting WAIT_FOR_BEFORE_START to / and deploying a root application, the connectors will start as expected.
Clone Of: 1050033
(edit)
Last Closed: 2014-06-28 15:24:56 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1099050 None None None Never

Internal Trackers: 1099050

Description Aaron Ogburn 2014-01-08 20:38:35 UTC
+++ This bug was initially created as a clone of Bug #1050033 +++

Description of problem:

WAIT_FOR_BEFORE_START does not work for / context applications.  If you set WAIT_FOR_BEFORE_START to / and deploy a / application, the connectors never start.


Version-Release number of selected component (if applicable):

EAP 6.2.0


How reproducible:

Always


Steps to Reproduce:
1. ./standalone.sh -Dorg.apache.catalina.connector.WAIT_FOR_BEFORE_START=/
2. Deploy a / context
3. Check and see that the connectors never started as expected after / was deployed

Actual results:

Connectors never start with WAIT_FOR_BEFORE_START=/

Expected results:

Connectors start with WAIT_FOR_BEFORE_START=/ when / context app is deployed

Additional info:

It gets the newly started context through context.getPath().  When deployed to /, context.getPath() is returning "" so that doesn't match the "/" value specified on WAIT_BEFORE_START and so the condition is never satisfied.  WAIT_BEFORE_START can't be set to "" to get a matching value there since only values containing "/" are effectively used.

--- Additional comment from Aaron Ogburn on 2014-01-08 15:18:45 EST ---

PR:

https://github.com/jbossas/jboss-eap/pull/762

Comment 1 Aaron Ogburn 2014-01-08 20:48:17 UTC
6.0.x PR:

https://github.com/jbossas/jboss-eap/pull/763

Comment 2 Aaron Ogburn 2014-01-08 22:40:50 UTC
Correct 6.x PR:

https://github.com/jbossas/jboss-eap/pull/768

Comment 3 Radim Hatlapatka 2014-02-17 11:14:27 UTC
Verified in EAP 6.3.0.DR0


Note You need to log in before you can comment on or make changes to this bug.