Bug 1050081 - send_xattr_request: Assertion `f_out >= 0' failed.
Summary: send_xattr_request: Assertion `f_out >= 0' failed.
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rsync
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Šimerda (pavlix)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1048659 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-08 16:54 UTC by Account closed by the user
Modified: 2014-11-16 10:15 UTC (History)
6 users (show)

Fixed In Version: rsync-3.1.0-4.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-16 10:15:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Samba Project 10364 None None None Never

Description Account closed by the user 2014-01-08 16:54:23 UTC
# rsync   --exclude='/swapfile' \
          --exclude='/home/*/.gvfs' \
          --exclude='/tmp/*' \
          --exclude='/var/tmp/*' \
          -A -X -a -H -x -v --delete / /mybook/raiz-t61-p.f20/
[...]
var/lib/mlocate/mlocate.db
rsync: xattrs.c:572: send_xattr_request: Assertion `f_out >= 0' failed.
rsync: connection unexpectedly closed (35060 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.0pre1]

# df | grep ext4
/dev/sda1 on / type ext4 (rw,noatime,discard,data=ordered)
/dev/sdb on /mybook type ext4 (rw,noatime,data=ordered)

Comment 1 Michal Luscon 2014-01-09 11:01:08 UTC
Are you able to confirm this flaw on rsync-3.1.0-2.fc20?

http://koji.fedoraproject.org/koji/buildinfo?buildID=472656

Comment 2 Account closed by the user 2014-01-09 11:07:31 UTC
(In reply to Michal Luscon from comment #1)
> Are you able to confirm this flaw on rsync-3.1.0-2.fc20?
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=472656

Yes:
rsync-3.1.0-2.fc20.x86_64

[...]
rsync: xattrs.c:572: send_xattr_request: Assertion `f_out >= 0' failed.
rsync: connection unexpectedly closed (37655 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.0]

Comment 3 Account closed by the user 2014-01-24 15:13:13 UTC
upstream workaround: use the "--protocol=30" option

Comment 4 Fedora Update System 2014-05-26 12:03:54 UTC
rsync-3.1.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rsync-3.1.0-4.fc20

Comment 5 Fedora Update System 2014-05-26 23:57:18 UTC
Package rsync-3.1.0-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rsync-3.1.0-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6715/rsync-3.1.0-4.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-05-28 23:55:05 UTC
rsync-3.1.0-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Adam Williamson 2014-05-29 18:41:04 UTC
This 'fix' has apparently somehow broken live installation:

https://bugzilla.redhat.com/show_bug.cgi?id=1101557

and someone's seeing the same problem just doing a local rsync:

https://bugzilla.redhat.com/show_bug.cgi?id=1101557#c19

Comment 8 Adam Williamson 2014-05-30 15:30:33 UTC
thanks a lot. so, should we open a new upstream bug? I added a comment to the existing one, but sometimes comments on closed bugs don't get noticed :/ I'd imagine this would be important to upstream for their 3.1.1 release...

Comment 9 Account closed by the user 2014-05-31 11:43:01 UTC
This bug still is present in rsync-3.1.0-5.fc20.x86_64

--cut---
[...]
rsync: xattrs.c:572: send_xattr_request: Assertion `f_out >= 0' failed.
rsync: connection unexpectedly closed (42469 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [sender=3.1.0]
--end---

Comment 10 Adam Williamson 2014-05-31 20:01:06 UTC
That is expected. We reverted the fix for this bug because it was causing other problems. We need to find a way to fix this which does *not* cause the problems reported in https://bugzilla.redhat.com/show_bug.cgi?id=1101557 .

Comment 11 Michal Luscon 2014-06-13 11:48:13 UTC
*** Bug 1048659 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Admin XMLRPC Client 2014-09-30 12:14:10 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.


Note You need to log in before you can comment on or make changes to this bug.