Bug 1050792 - [abrt] python-boto: auth.py:728:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV4Handler'] Check your credentials
[abrt] python-boto: auth.py:728:get_auth_handler:NoAuthHandlerFound: No handl...
Status: CLOSED DUPLICATE of bug 821799
Product: Fedora
Classification: Fedora
Component: python-boto (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Garrett Holmstrom
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:d90ac893a5387ab209345b9644e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-09 00:23 EST by jan p. springer
Modified: 2014-08-22 17:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-22 17:02:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.38 KB, text/plain)
2014-01-09 00:23 EST, jan p. springer
no flags Details
File: environ (3.36 KB, text/plain)
2014-01-09 00:23 EST, jan p. springer
no flags Details

  None (edit)
Description jan p. springer 2014-01-09 00:23:46 EST
Version-Release number of selected component:
python-boto-2.13.3-1.fc19

Additional info:
reporter:       libreport-2.1.10
cmdline:        /usr/bin/python /usr/bin/cq
executable:     /usr/bin/cq
kernel:         3.12.6-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
auth.py:728:get_auth_handler:NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV4Handler'] Check your credentials

Traceback (most recent call last):
  File "/usr/bin/cq", line 88, in <module>
    main()
  File "/usr/bin/cq", line 61, in main
    c = SQSConnection()
  File "/usr/lib/python2.7/site-packages/boto/sqs/connection.py", line 59, in __init__
    validate_certs=validate_certs)
  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 998, in __init__
    validate_certs=validate_certs)
  File "/usr/lib/python2.7/site-packages/boto/connection.py", line 557, in __init__
    host, config, self.provider, self._required_auth_capability())
  File "/usr/lib/python2.7/site-packages/boto/auth.py", line 728, in get_auth_handler
    'Check your credentials' % (len(names), str(names)))
NoAuthHandlerFound: No handler was ready to authenticate. 1 handlers were checked. ['HmacAuthV4Handler'] Check your credentials

Local variables in innermost frame:
total_handlers: 1
checked_handlers: [<class 'boto.auth.HmacAuthV4Handler'>]
provider: <boto.provider.Provider object at 0x13537d0>
host: 'queue.amazonaws.com'
handler: <class 'boto.auth.HmacAuthV4Handler'>
names: ['HmacAuthV4Handler']
ready_handlers: []
requested_capability: ['hmac-v4']
auth_handlers: [<class 'boto.auth.HmacAuthV4Handler'>]
config: <boto.pyami.config.Config instance at 0x7fa43edfb680>
Comment 1 jan p. springer 2014-01-09 00:23:54 EST
Created attachment 847480 [details]
File: backtrace
Comment 2 jan p. springer 2014-01-09 00:23:57 EST
Created attachment 847481 [details]
File: environ
Comment 3 Garrett Holmstrom 2014-08-22 17:02:24 EDT

*** This bug has been marked as a duplicate of bug 821799 ***

Note You need to log in before you can comment on or make changes to this bug.