Bug 1050963 - [GSS] (6.3) Permanent fix for: org.jboss.weld.exceptions.DeploymentException: WELD-001414 Bean name is ambiguous
Summary: [GSS] (6.3) Permanent fix for: org.jboss.weld.exceptions.DeploymentException:...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CDI/Weld
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR0
: EAP 6.3.0
Assignee: Jozef Hartinger
QA Contact: Marek Schmidt
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1051638 1052277
TreeView+ depends on / blocked
 
Reported: 2014-01-09 12:43 UTC by Adam Kovari
Modified: 2018-12-09 17:24 UTC (History)
9 users (show)

(edit)
Bean name ambiguity validation was not isolated in deployments with multiple sub-deployments, and this caused  `DeploymentException` in some scenarios. This has been resolved with an upgrade of the Weld component in this release of Red Hat JBoss EAP 6.
Clone Of: 1050959
: 1052277 (view as bug list)
(edit)
Last Closed: 2014-06-28 15:43:20 UTC


Attachments (Terms of Use)
Reproducer (maven) project (51.28 KB, application/zip)
2014-01-09 13:23 UTC, wfink
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1242113 None None None Never
JBoss Issue Tracker WELD-1584 Major Resolved Ambiguous name validation should not cross visibility boundaries 2017-12-07 13:43 UTC

Description Adam Kovari 2014-01-09 12:43:47 UTC
+++ This bug was initially created as a clone of Bug #1050959 +++

Description of problem:
org.jboss.weld.exceptions.DeploymentException: WELD-001414 Bean name is ambiguous when deploying application

Version-Release number of selected component (if applicable):
EAP 6.0.1

How reproducible:
See attached reproducer

Steps to Reproduce:
1. Build project
2. Deploy

Comment 1 wfink 2014-01-09 13:23:41 UTC
Created attachment 847646 [details]
Reproducer (maven) project

I test the project with EAP6.2.0 with the same result.

14:19:14,822 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-13) MSC000001: Failed to start service jboss.deployment.unit."twoWarProject.ear".WeldStartService: org.jboss.msc.service.StartException in service jboss.deployment.unit."twoWarProject.ear".WeldStartService: Failed to start service
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_45]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_45]
	at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]
Caused by: org.jboss.weld.exceptions.DeploymentException: WELD-001414 Bean name is ambiguous. Name echo resolves to beans [Managed Bean [class org.jboss.tools.s2.EchoS2] with qualifiers [@Any @Default @Named], Managed Bean [class org.jboss.tools.s1.EchoS1] with qualifiers [@Any @Default @Named]]
	at org.jboss.weld.bootstrap.Validator.validateBeanNames(Validator.java:480)
	at org.jboss.weld.bootstrap.Validator.validateDeployment(Validator.java:374)
	at org.jboss.weld.bootstrap.WeldBootstrap.validateBeans(WeldBootstrap.java:379)
	at org.jboss.as.weld.WeldStartService.start(WeldStartService.java:64)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	... 3 more

14:19:15,032 ERROR [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS015870: Deploy of deployment "twoWarProject.ear" was rolled back with the following failure message: 
{"JBAS014671: Failed services" => {"jboss.deployment.unit.\"twoWarProject.ear\".WeldStartService" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"twoWarProject.ear\".WeldStartService: Failed to start service
    Caused by: org.jboss.weld.exceptions.DeploymentException: WELD-001414 Bean name is ambiguous. Name echo resolves to beans [Managed Bean [class org.jboss.tools.s2.EchoS2] with qualifiers [@Any @Default @Named], Managed Bean [class org.jboss.tools.s1.EchoS1] with qualifiers [@Any @Default @Named]]"}}

Comment 2 Jozef Hartinger 2014-01-10 14:49:12 UTC
Fixed upstream. The fix will be available in Weld 1.1.17.Final

Comment 3 JBoss JIRA Server 2014-01-21 08:46:48 UTC
Marek Schmidt <maschmid@redhat.com> updated the status of jira WELD-1584 to Reopened

Comment 4 JBoss JIRA Server 2014-01-28 16:59:22 UTC
Jozef Hartinger <jharting@redhat.com> updated the status of jira WELD-1584 to Resolved

Comment 5 Kabir Khan 2014-04-04 14:36:35 UTC
Setting to ON_QA since upgrade should fix this

Comment 6 Marek Schmidt 2014-04-07 10:48:26 UTC
Verified on EAP 6.3.0.ER1


Note You need to log in before you can comment on or make changes to this bug.