Bug 1052277 - [GSS] (6.2.x) Permanent fix for: org.jboss.weld.exceptions.DeploymentException: WELD-001414 Bean name is ambiguous
Summary: [GSS] (6.2.x) Permanent fix for: org.jboss.weld.exceptions.DeploymentExceptio...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CDI/Weld
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: CR3
: EAP 6.2.1
Assignee: Adam Kovari
QA Contact: Marek Schmidt
Russell Dickenson
URL:
Whiteboard:
Depends On: 1050963
Blocks: eap62-cp01-blockers 1050959 1051642
TreeView+ depends on / blocked
 
Reported: 2014-01-13 14:51 UTC by Brad Maxwell
Modified: 2018-12-05 16:55 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Bean name ambiguity validation was not isolated in deployments with multiple sub-deployments, and this caused `DeploymentException` in some scenarios. This has been resolved with an upgrade of the Weld component in this release of Red Hat JBoss EAP 6.
Clone Of: 1050963
Environment:
Last Closed: 2014-02-24 20:15:34 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker WELD-1584 Major Resolved Ambiguous name validation should not cross visibility boundaries 2018-08-03 09:49:16 UTC

Description Brad Maxwell 2014-01-13 14:51:03 UTC
+++ This bug was initially created as a clone of Bug #1050963 +++

+++ This bug was initially created as a clone of Bug #1050959 +++

Description of problem:
org.jboss.weld.exceptions.DeploymentException: WELD-001414 Bean name is ambiguous when deploying application

Version-Release number of selected component (if applicable):
EAP 6.0.1

How reproducible:
See attached reproducer

Steps to Reproduce:
1. Build project
2. Deploy

--- Additional comment from  on 2014-01-09 08:23:41 EST ---

I test the project with EAP6.2.0 with the same result.

14:19:14,822 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-13) MSC000001: Failed to start service jboss.deployment.unit."twoWarProject.ear".WeldStartService: org.jboss.msc.service.StartException in service jboss.deployment.unit."twoWarProject.ear".WeldStartService: Failed to start service
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_45]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_45]
	at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]
Caused by: org.jboss.weld.exceptions.DeploymentException: WELD-001414 Bean name is ambiguous. Name echo resolves to beans [Managed Bean [class org.jboss.tools.s2.EchoS2] with qualifiers [@Any @Default @Named], Managed Bean [class org.jboss.tools.s1.EchoS1] with qualifiers [@Any @Default @Named]]
	at org.jboss.weld.bootstrap.Validator.validateBeanNames(Validator.java:480)
	at org.jboss.weld.bootstrap.Validator.validateDeployment(Validator.java:374)
	at org.jboss.weld.bootstrap.WeldBootstrap.validateBeans(WeldBootstrap.java:379)
	at org.jboss.as.weld.WeldStartService.start(WeldStartService.java:64)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	... 3 more

14:19:15,032 ERROR [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS015870: Deploy of deployment "twoWarProject.ear" was rolled back with the following failure message: 
{"JBAS014671: Failed services" => {"jboss.deployment.unit.\"twoWarProject.ear\".WeldStartService" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"twoWarProject.ear\".WeldStartService: Failed to start service
    Caused by: org.jboss.weld.exceptions.DeploymentException: WELD-001414 Bean name is ambiguous. Name echo resolves to beans [Managed Bean [class org.jboss.tools.s2.EchoS2] with qualifiers [@Any @Default @Named], Managed Bean [class org.jboss.tools.s1.EchoS1] with qualifiers [@Any @Default @Named]]"}}

--- Additional comment from Jozef Hartinger on 2014-01-10 09:49:12 EST ---

Fixed upstream. The fix will be available in Weld 1.1.17.Final

Comment 3 Scott Mumford 2014-01-17 02:19:09 UTC
A draft release note has been added to the Docs Text field above.

Comment 4 JBoss JIRA Server 2014-01-21 08:46:51 UTC
Marek Schmidt <maschmid@redhat.com> updated the status of jira WELD-1584 to Reopened

Comment 5 Marek Schmidt 2014-01-23 15:48:34 UTC
The fix introduces a regression, https://bugzilla.redhat.com/show_bug.cgi?id=1057134

Changing back to assigned so it can be verified again properly together with the fix for #1057134.

Comment 6 Vaclav Tunka 2014-01-24 18:13:34 UTC
Setting back to modified:
https://github.com/jbossas/jboss-eap/pull/849

Comment 7 JBoss JIRA Server 2014-01-28 16:59:25 UTC
Jozef Hartinger <jharting@redhat.com> updated the status of jira WELD-1584 to Resolved

Comment 8 Marek Schmidt 2014-01-29 10:52:12 UTC
Verified on EAP 6.2.1.CP.CR3

Comment 9 Lucas Costi 2014-01-31 03:23:57 UTC
Release note for 6.2.1 +'d


Note You need to log in before you can comment on or make changes to this bug.