Bug 1051937 - system-config-users not start in Mate Desktop
Summary: system-config-users not start in Mate Desktop
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-panel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Mashal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-12 23:35 UTC by William Moreno
Modified: 2014-01-14 18:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-14 18:16:26 UTC


Attachments (Terms of Use)
screenshot (534.92 KB, image/png)
2014-01-12 23:35 UTC, William Moreno
no flags Details

Description William Moreno 2014-01-12 23:35:26 UTC
Created attachment 849073 [details]
screenshot

Description of problem:
With a normal user the system-config-users don't start from the system menu

Version-Release number of selected component (if applicable):


How reproducible:
Loging with into Mate Desktop
Try to open one admin tool from the menu


Steps to Reproduce:
1. Loggin in Mate
2. Try to open a admin tool from menu
3.

Actual results:


Expected results:


Additional info:
If run tool from command line the output is:

[william@localhost ~]$ system-config-users
==== AUTHENTICATING FOR org.fedoraproject.config.users.pkexec.run ===
Authentication is required to run system-config-users
Authenticating as: William Moreno Reyes (william)
Password: 

After logging in terminal the tool open well:

[william@localhost ~]$ system-config-users
==== AUTHENTICATING FOR org.fedoraproject.config.users.pkexec.run ===
Authentication is required to run system-config-users
Authenticating as: William Moreno Reyes (william)
Password: 
==== AUTHENTICATION COMPLETE ===

If appear than non root user can not open this admin tool, or even user than have administrative privilegios can not open this tool with giving the pass word in a terminal

Comment 1 William Moreno 2014-01-12 23:46:08 UTC
Similar report:

https://bugzilla.redhat.com/show_bug.cgi?id=242822

Comment 2 William Moreno 2014-01-12 23:46:54 UTC
Report upstream:

https://github.com/mate-desktop/mate-desktop/issues/92

Comment 3 William Moreno 2014-01-12 23:53:28 UTC
Current mate version:

mate-desktop-1.6.2-0.12.git81c245b.fc20.x86_64

Comment 4 Wolfgang Ulbrich 2014-01-13 14:53:33 UTC
Hmm,
here it works in f20 with mate-panel-1.6.1-4 from the menu under /system/administration/system-config-users.
A polkit popup window opened and ask you for a password.
That's normal behaviour that you need a password.
Is mate-polkit installed?

Comment 5 William Moreno 2014-01-14 04:17:07 UTC
yum install mate-keyring
Complementos cargados:langpacks
El paquete mate-keyring-1.6.0-3.fc20.x86_64 se hace obsoleto con mate-desktop-1.6.2-0.12.git81c245b.fc20.x86_64, que ya se encuentra instalado
Nada para hacer


It is suposed to don't be necesary, but I have 

[root@localhost william]# rpm -q mate-desktop
mate-desktop-1.6.2-0.12.git81c245b.fc20.x86_64

So I think it is not working :(

Comment 6 Wolfgang Ulbrich 2014-01-14 15:23:55 UTC
I think i know your problem;)
How did you installed Mate?
Using 'yum install mate-desktop' is wrong !!!
Because 'mate-desktop' isn't a meta package.
The right way for installing the Mate destop is to use
'yum groupinstall mate-desktop'
This will install all necessary packages for a working desktop.
Install instructions:
http://wiki.mate-desktop.org/download#fedora

PS: mate-keyring/libmatekeyring is obsolete, mate use libsecret/gnomekeyring in f20

Comment 7 William Moreno 2014-01-14 16:39:40 UTC
I install from live CD, but keep my /home

So I deleted all configuration files from past install and work fine, thanks


Note You need to log in before you can comment on or make changes to this bug.