Bug 1051991 - [GSS] (6.3.z) JMS destination statistics weren't shown on the admin console [NEEDINFO]
Summary: [GSS] (6.3.z) JMS destination statistics weren't shown on the admin console
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console
Version: 6.2.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: EAP 6.3.2
Assignee: Heiko Braun
QA Contact: Jakub Cechacek
Russell Dickenson
URL:
Whiteboard:
Keywords: Reopened, Triaged
Depends On: 1121495
Blocks: eap631-blockers, eap631-payload, eap63-cp01-blockers 1128755
TreeView+ depends on / blocked
 
Reported: 2014-01-13 04:22 UTC by Tyronne Wickramarathne
Modified: 2019-05-20 11:07 UTC (History)
17 users (show)

(edit)
This release of JBoss EAP 6 carries a bug that prevent the Admin Console from displaying the correct number of JMS destinations. The figure is always displayed as `0`.

This issue is expected to be resolved in a future release of the product.
Clone Of:
: 1121495 (view as bug list)
(edit)
Last Closed: 2014-10-14 12:59:46 UTC
cdewolf: needinfo? (myarboro)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker HAL-401 Major Resolved JMS destination statistics are not shown on the admin console 2017-03-28 14:51 UTC
JBoss Issue Tracker WFLY-3325 Major Resolved The WildFly Console is not able to display the JMS Metrics 2017-03-28 14:51 UTC

Description Tyronne Wickramarathne 2014-01-13 04:22:15 UTC
Description of problem:
JBoss-EAP-6.2 does not show message count for JMS destinations on the admin console.

Version-Release number of selected component (if applicable):
JBoss-EAP-6.2 
HornetQ-2.3.12

How reproducible:
Always

Steps to Reproduce:

1. Create a JMS destination using admin console, CLI or directly on the standalone configuration file 

<jms-destinations>
   <jms-queue name="M">
      <entry name="java:/jboss/exported/queue/M"/>
      <durable>true</durable>
   </jms-queue>
</jms-destinations>

2. Send 1 or more messages using a JMS client to the newly configured destination 

3. Open the admin console and check the message count for the said destination, queue/M
http://localhost:9990/console/App.html#jms-metrics


Actual results:
The admin console does not show message count. It shows '0' as the message count

Expected results:
Admin console should display the actual message count 

Additional info:
You could verify the actual message count via CLI as a workaround since it shows the message count correctly :

[standalone@localhost:9999 /] /subsystem=messaging/hornetq-server=default/jms-queue=M:count-messages()      
{
    "outcome" => "success",
    "result" => 10L
}

Comment 1 Yong Hao Gao 2014-04-14 14:36:44 UTC
Hi Tyronne,

I think this bug is in admin console. I observed both cli and console invoke the getMessageCount() method, however the cli correctly printed it but the console doesn't.

I need to find the AS 7.2.0 source to debug. I downloaded the src zip but I got build failure. Do you know where to get the correct source code?


Thanks
Howard

Comment 11 Harald Pehl 2014-06-16 15:23:12 UTC
Unfortunately it's too late to include this into 6.3. I suggest to postpone the fix  for EAP 6.4.

Comment 15 JBoss JIRA Server 2014-06-29 21:46:55 UTC
Harald Pehl <hpehl@redhat.com> updated the status of jira HAL-401 to Coding In Progress

Comment 17 JBoss JIRA Server 2014-07-02 12:27:55 UTC
Heiko Braun <ike.braun@googlemail.com> updated the status of jira HAL-401 to Resolved

Comment 18 Scott Mumford 2014-07-17 04:15:08 UTC
Making public for inclusion in 6.3.0 Release Notes.

Comment 22 Jakub Cechacek 2014-08-28 10:46:11 UTC
Verified EAP 6.3 1.CP.CR1

Comment 28 Rostislav Svoboda 2014-10-14 12:59:46 UTC
We (QE) think issues described in the BZ was properly fixed in EAP 6.3 1.CP.CR1.

There are many customer cases linked to this BZ. I think in some of these there are different problems than what is the scope of this BZ - for example https://access.redhat.com/support/cases/01212225/
  - runtime destinations for topic (tab "subscriptions") doesn't show details per subscriber, only general information about number of consumers and messages

Please file new BZ for additional requests from customer tickets.


Note You need to log in before you can comment on or make changes to this bug.