Bug 1053704 - Faulty storage check when adding a new disk
Summary: Faulty storage check when adding a new disk
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: All
high
high
Target Milestone: ---
: 3.4.0
Assignee: Vered Volansky
QA Contact: Elad
URL:
Whiteboard: storage
: 1091712 (view as bug list)
Depends On:
Blocks: 960934
TreeView+ depends on / blocked
 
Reported: 2014-01-15 16:38 UTC by Allon Mureinik
Modified: 2016-02-10 18:59 UTC (History)
17 users (show)

Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Clone Of: 960934
: 1053742 (view as bug list)
Environment:
Last Closed: 2014-03-31 12:30:37 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 15377 0 None None None Never

Description Allon Mureinik 2014-01-15 16:38:34 UTC
+++ This bug was initially created as a clone of Bug #960934 +++

Description of problem:

For new empty disks, the required space validations should be:
      | File Domain                             | Block Domain
 -----|-----------------------------------------|-------------
 qcow | 1M (header size)                        | 1G
 -----|-----------------------------------------|-------------
 raw  | preallocated: disk capacity (getSize()) | disk capacity
      | thin (sparse): 1M                       | (there is no raw sparse on 
                                                   block domains)

Comment 1 Raz Tamir 2014-02-17 13:49:42 UTC
Allon, please provide step to reproduce

Comment 2 Allon Mureinik 2014-02-18 16:17:32 UTC
the following permutations could(1) be tested:
- file(NFS) vs. block (iSCSI)
- qcow vs. raw
- preallocated vs sparse (only for file domain)

1. Create a storage domain with 10GB free space.
2. Attempt to create a 9GB disk

expected results:
- qcow should succeed in any domain
- raw on block should fail
- raw preallocated should fail
- raw sparse should succeed

[1] Up to QA to decide which parts of this matrix you actually want to test.

Comment 3 Elad 2014-02-24 14:11:03 UTC
I've tested the following scenarios:

On block (iSCSI) domain with 5G free space:
- 6G preallocated disk - blocked
- 6G thin-provision disk - succeeded

On file (NFS) domain with 13G free space:
- 14G preallocated disk - blocked
- 14G thin-provision disk - succeeded


Allon, is it satisfying? Can I move to VERIFIED?

Comment 4 Allon Mureinik 2014-02-27 11:41:23 UTC
(In reply to Elad from comment #3)
> I've tested the following scenarios:
> 
> On block (iSCSI) domain with 5G free space:
> - 6G preallocated disk - blocked
> - 6G thin-provision disk - succeeded
> 
> On file (NFS) domain with 13G free space:
> - 14G preallocated disk - blocked
> - 14G thin-provision disk - succeeded
> 
> 
> Allon, is it satisfying? Can I move to VERIFIED?

Looks good to me.
Moving to VERIFIED based on comment 3.

Comment 5 Sandro Bonazzola 2014-03-31 12:30:37 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Comment 6 Allon Mureinik 2014-04-28 16:00:02 UTC
*** Bug 1091712 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.