Bug 1053891 - emacs fails to start when running KDE
Summary: emacs fails to start when running KDE
Keywords:
Status: CLOSED DUPLICATE of bug 1043686
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kdebase-workspace
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: 7.0
Assignee: Ngo Than
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 722241
TreeView+ depends on / blocked
 
Reported: 2014-01-15 22:39 UTC by George Beshers
Modified: 2014-11-04 14:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-14 10:00:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description George Beshers 2014-01-15 22:39:36 UTC
Description of problem:

    I installed rhel7 snap1 on my desktop (well did an upgrade)
    and included KDE.

    From konsole 'emacs file.txt' returns
    Undefined color: "WINDOW_FOREGROUND"

[gbeshers@sgi-desk BIOS_xe320]$ emacs -fg black file.txt
Undefined color: "WINDOW_BACKGROUND"
[gbeshers@sgi-desk BIOS_xe320]$ emacs -fg black -bg white file.text
Undefined color: "WINDOW_FOREGROUND"

Starting emacs from a 6.5 machine in the lab produced the
same output.


Version-Release number of selected component (if applicable):


How reproducible:
   Always on my desktop.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Petr Hracek 2014-01-16 10:05:08 UTC
Hi George,

thanks for the bug.
But it seems to be like a bug in xorg-server-utils which did not provide the
variable WINDOW_FOREGROUND

I will clarify that.

I tested on the latest RHEL-7 system whether emacs is starting and result is
that under GNOME and Cinnamon all is working properly.

Unfortunatelly under KDE not.

Your emacs version is 24.3, right?

greeting
Petr

Comment 3 George Beshers 2014-01-16 16:28:31 UTC
Hi Petr,

I suspected that it might be KDE setup.
What puzzled me is why the command line arguments failed??

If I had been able to get it working with -fg -bg etc.
then I wouldn't have filed it against emacs.

If your confident emacs isn't the culprit do you know
who to ask next?

[gbeshers@sgi-desk ~]$ emacs --version
GNU Emacs 24.3.1
Copyright (C) 2013 Free Software Foundation, Inc.
GNU Emacs comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of Emacs
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.

Cheers,
George

Comment 4 Petr Hracek 2014-01-17 08:57:36 UTC
Hi George,

finally I've got an answer from upstream
====
This is outside of Emacs control.  There are some files that expects to be run through the preprocessor, but isn't.  It is usually Emacs.ad, located somewhere in /etc/X11 or /usr/lib/X11 or /usr/share/X11, or with xorg instead of X11.  This error comes up now and then.
If you find the Emacs.ad file, try removing it.  You may have to restart X after that.

Also do

% xrdb -query

and you will see if the WINDOW_FOREGROUND is set just for Emacs or globally.  If it is globally, removing Emacs.ad wont help, some other file isn't preprocessed properly.

The point is, this is not an Emacs bug, closing.
====

Please try the steps mentioned above and let me know whether it helps.

Comment 5 Petr Hracek 2014-02-12 08:12:46 UTC
Hi xrdb maintainer

could you please verify whether you provides colors like 
WINDOW_FOREGROUND or WINDOW_BACKGROUND

best regards

Comment 6 Adam Jackson 2014-02-13 17:52:43 UTC
xrdb in RHEL7 does not run the C preprocessor on resource files by default anymore.  It was running mcpp(1), which is dead upstream and which neither the X nor tools teams have the resources to maintain.  The alternative is running gcc's cpp, which we don't want to do by default because it drags in most of gcc, which most non-developer desktop scenarios neither need nor want.

I'm not sure where this WINDOW_FOREGROUND thing is coming from though.  It's not provided in any of the base X11 packages, nor do I see any string match for it in emacs itself.  And emacs seems to work just fine when run under Gnome, so I'm going to assume KDE is putting it in the resource db and assuming cpp expansion will happen.

KDE should either do this expansion itself, or require cpp.

Comment 7 Petr Hracek 2014-02-13 21:29:19 UTC
Switching to KDE team which can help me why the variables WINDOW_FOREGROUND|BACKGROUND lost.

I have checked emacs in GNOME and all is working properly.

Comment 8 Ngo Than 2014-02-14 10:00:14 UTC

*** This bug has been marked as a duplicate of bug 1043686 ***

Comment 9 Eric Smith 2014-08-30 23:15:06 UTC
Does emacs use tk (per the claim of being a duplicate of bug 1043686)?  I didn't think it did.

This happens with the MATE desktop (from EPEL7) also, not just KDE.

Comment 10 Eric Smith 2014-11-03 03:31:33 UTC
For similar problem with emacs with Mate desktop see bug #1140329.


Note You need to log in before you can comment on or make changes to this bug.