Bug 1140329 - X ressources are expected to be preprocessed when they actually aren't
Summary: X ressources are expected to be preprocessed when they actually aren't
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mate-settings-daemon
Version: epel7
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1148455 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-10 17:05 UTC by Michael Lampe
Modified: 2014-11-30 19:14 UTC (History)
7 users (show)

Fixed In Version: mate-settings-daemon-1.8.2-3.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-30 19:14:28 UTC
Type: Bug


Attachments (Terms of Use)

Description Michael Lampe 2014-09-10 17:05:53 UTC
Description of problem:

X ressources are expected to be preprocessed when they actually aren't

Version-Release number of selected component (if applicable):

1.8.0-1.el7

How reproducible:

Always.

Steps to Reproduce:

Start, for example, emacs.

Actual results:

Error Message is displayed and Emacs terminates.

Undefined color: "WINDOW_FOREGROUND"

Additional info:

https://bugzilla.redhat.com/show_bug.cgi?id=1053891

Comment 1 Eric Smith 2014-11-03 03:30:32 UTC
Still happening with emacs. Extremely annoying.

Comment 2 Wolfgang Ulbrich 2014-11-12 19:24:47 UTC
As a workaround until i found the culprit you can run
'gsettings get org.mate.SettingsDaemon.plugins.xrdb active false'
Couriously, exactly this plugin is responsible for setting the GdkColor map.

[rave@mother github-matedesktop]$ grep -n -i 'WINDOW_FOREGROUND' mate-settings-daemon/plugins/xrdb/*
mate-settings-daemon/plugins/xrdb/msd-xrdb-manager.c:124:                             "WINDOW_FOREGROUND",

Maybe it is broken here or it isn't needed in rhel7.

Comment 3 Wolfgang Ulbrich 2014-11-12 19:26:45 UTC
Don't forget to restart session after gsettings command.

Comment 4 Wolfgang Ulbrich 2014-11-12 19:54:05 UTC
opps, right command is
gsettings set org.mate.SettingsDaemon.plugins.xrdb active false

Comment 5 Fedora Update System 2014-11-12 22:55:42 UTC
mate-settings-daemon-1.8.2-2.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/mate-settings-daemon-1.8.2-2.el7

Comment 6 Michael Lampe 2014-11-12 23:24:12 UTC
Nice! But shouldn't this package now require cpp (for non-programmers)?

Comment 7 Wolfgang Ulbrich 2014-11-12 23:47:06 UTC
(In reply to Michael Lampe from comment #6)
> Nice! But shouldn't this package now require cpp (for non-programmers)?

Yes, i fix it in the same way like kde did it.
https://git.centos.org/blob/rpms!kde-workspace.git/511c81f3b376f326cd0f33c222b3f4b6e9a26aa4/SOURCES!kde-workspace-4.10.5-bz%231043686-cpp.patch
At mate upstream we think that something more general belongs to X in rhel7 cause this issue, because this fix isn't needed for f20/21.
But as fedora epel7 maintaner i don't have access on redhat git package resources, so it is imposible for me to search deeper.

Comment 8 Wolfgang Ulbrich 2014-11-13 00:05:24 UTC
Note, i edited the update right version is 1.8.2-3

Comment 9 Fedora Update System 2014-11-14 00:15:49 UTC
Package mate-settings-daemon-1.8.2-3.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mate-settings-daemon-1.8.2-3.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-4024/mate-settings-daemon-1.8.2-3.el7
then log in and leave karma (feedback).

Comment 10 Jaroslav Škarvada 2014-11-14 11:54:26 UTC
*** Bug 1148455 has been marked as a duplicate of this bug. ***

Comment 11 Jaroslav Škarvada 2014-11-14 12:01:43 UTC
It works in Fedora, because xrdb provided by xorg-x11-server-utils explicitly requires mcpp and by default pre-process X resources through mcpp.

However, the xrdb provided by xorg-x11-server-utils from RHEL-7 doesn't pre-process X resources through mcpp, nor it requires mcpp:

%changelog
- xrdb: Default to -nocpp
- Drop Requires: mcpp to match; install cpp if you need it.

This is exactly what this mate-settings-daemon update did, so I think it's the correct fix.

Comment 12 Jaroslav Škarvada 2014-11-14 12:03:31 UTC
(In reply to Jaroslav Škarvada from comment #11)
> %changelog
> - xrdb: Default to -nocpp
> - Drop Requires: mcpp to match; install cpp if you need it.
> 

Ups, change with header:

Wed Oct 02 2013 Adam Jackson <ajax@redhat.com> 7.7-2
- xrdb: Default to -nocpp
- Drop Requires: mcpp to match; install cpp if you need it.

Comment 13 Wolfgang Ulbrich 2014-11-14 18:31:02 UTC
Thanks for info Jaroslav,
this let me think that it should be fixed xorg-x11-server-utils.
No for mate, becauase epel7 is a third party repo from rhel7 point of view,
but kde is an official rhel7 desktop.

Comment 14 Michael Lampe 2014-11-14 18:38:07 UTC
Here, someone from RH says that not preprocessing X resources in RHEL7 is deliberate: https://bugzilla.redhat.com/show_bug.cgi?id=1053891#c6

This fix in mate-settings-daemon is therefore required for EPEL7.

Comment 15 Fedora Update System 2014-11-30 19:14:28 UTC
mate-settings-daemon-1.8.2-3.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.