Bug 1054205 - [RFE] visualize boot order dialog to make it clear what's going to happen based on what devices do/do not exist in the VM
Summary: [RFE] visualize boot order dialog to make it clear what's going to happen bas...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: ---
Hardware: Unspecified
OS: Unspecified
low
high vote
Target Milestone: ovirt-4.3.0
: ---
Assignee: Michal Skrivanek
QA Contact: Pavel Stehlik
URL:
Whiteboard:
: 1132052 (view as bug list)
Depends On:
Blocks: GSS_RHEV_33_BETA 1127644
TreeView+ depends on / blocked
 
Reported: 2014-01-16 12:55 UTC by Tomas Dosek
Modified: 2019-04-28 10:03 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-06 16:13:58 UTC
oVirt Team: Virt
mtessun: ovirt-4.3?
mtessun: planning_ack+
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Tomas Dosek 2014-01-16 12:55:05 UTC
Description of problem:
Webadmin allows user to create vm without nic, select pxe as first boot and start such VM

Version-Release number of selected component (if applicable):
is29

How reproducible:
100 %

Steps to Reproduce:
1. create vm with a disk
2. do not attach it with nic
3. select pxe boot in boot devices
4. start the vm

Actual results:
It possible to start the VM

Expected results:
It should not be possible to pass pxe boot to a vm without nic 

Additional info:
hopefully not needed

Comment 1 Michal Skrivanek 2014-01-17 11:30:02 UTC
CDROM behaves the same, i.e. add CDROM in boot devices but do not attach any.
Still allows you to start the VM

Comment 6 Bill Sanford 2014-01-22 21:21:23 UTC

*** This bug has been marked as a duplicate of bug 1034947 ***

Comment 7 Michal Skrivanek 2014-01-23 08:03:16 UTC
Bill, how is this a dupe?

Comment 8 Doron Fediuck 2014-01-23 12:39:41 UTC
(In reply to Scott Herold from comment #5)
> How are users "failing" with this?  The VM still boots and runs.  Does it
> jump past PXE Boot on the guest if it doesn't detect the NIC and defer to
> the remaining startup device list?  Just trying to make sure this is
> prioritized properly for 3.3.z vs. other items in the backlog.

I created a VM which I wanted to boot from PXE.
So I went to boot order and made sure network if first, disk 2nd.
Then started the VM. It went directly to the disk, skipping PXE which
made me angry. 
So I removed the disk to do network only boot. At that point I got an error
that I have no network configured.
Grrr..... Please do not handle users this way. I spent ~15 minutes on debugging
it.

Comment 9 Michal Skrivanek 2014-01-23 13:38:11 UTC
Doron, how does that make it a boot order issue?
Skipping PXE when there is no NIC is not a problem of the boot process.
That the VM representation is maybe not visual enough when it is NIC-less or disk-less, fine, but that's a different issue
In any case I don't expect this is a big deal once we have bug 1047624

Bill, comment #7

Comment 10 Bill Sanford 2014-01-23 20:48:31 UTC
Michal, how is it not a dupe? In is26, after the initial VM creation, the subsequent functionality of the dialog box containing the VM disk and VM network was changed to just the VM disk being added. That meant that the VM on initial creation had to have the NIC selected (It was grayed out) and if you didn't know that you had to change the value. This resulted in the VM creation without the NIC. 

There is a part where I say that you have to shutdown the VM and change the value of the NIC and enable it. My exact words: "The administrator now has a VM with no networking and must shutdown the VM and manually add it from editing the VM in RHEV-M." It started without the NIC enabled. It is the exact same thing the original bug.

Comment 11 Michal Skrivanek 2014-01-24 13:25:54 UTC
Bill, I may be missing something, but reading the description of this very bug talks about something else.
You are intentionally able to create a VM without NIC. The fact you did it by mistake/misleading screen is a different matter. (I reopened that bug because it is indeed misleading and definitely not the experience we were redesigning the dialog for)


- reopening this one, would use WONTFIX, but keeping it open as there seems to be something fishy with CDs as well. 
- removing 3.3.z as it so far looks "mostly harmless"

Comment 13 Doron Fediuck 2014-01-28 16:20:56 UTC
(In reply to Michal Skrivanek from comment #9)
> Doron, how does that make it a boot order issue?
> Skipping PXE when there is no NIC is not a problem of the boot process.
> That the VM representation is maybe not visual enough when it is NIC-less or
> disk-less, fine, but that's a different issue
> In any case I don't expect this is a big deal once we have bug 1047624
> 

As I wrote, nic-less / disk-less VMs should be represented properly in the boot order as well, or the user does not understand the problem. 

The main issue is that we now have a default scenario that bites the user;
/ANY/ user who wants to install a VM from PXE, and follows the default path
will fail.

What we should have is a trivial new VM dialog that ends up running, rather than failing without explanation (in this case no bootable device is not the explanation to a missing NIC).

Comment 16 Michal Skrivanek 2014-08-22 08:31:45 UTC
rephrasing as RFE

1. we want users to start a VM without CD, without NIC, without disk
2. we want to allow boot order to specify all possible combination
3. we want to make clear user understands what's going to happen
    e.g. when you are setting "boot from pxe" it should be reflected somewhere that the VM doesn't have a NIC.

Comment 17 Michal Skrivanek 2014-08-22 08:32:14 UTC
*** Bug 1132052 has been marked as a duplicate of this bug. ***

Comment 19 Daniel Erez 2016-06-07 12:26:18 UTC
*** Bug 1336708 has been marked as a duplicate of this bug. ***

Comment 20 Martin Tessun 2018-07-06 16:13:58 UTC
Just realizing it works this way in RHV 4.2 at least in the RunOnce dialogue, which is the important one as this is typically used to install the VM, as you do not want to keep it booting from Network typically.


Note You need to log in before you can comment on or make changes to this bug.