Bug 1055118 - Files icon improperly displayed in Alt-Tab list and crashes gnome-shell if selected
Summary: Files icon improperly displayed in Alt-Tab list and crashes gnome-shell if se...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell   
(Show other bugs)
Version: 20
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Regression
: 1057278 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-18 22:10 UTC by Robert Hancock
Modified: 2014-01-26 00:29 UTC (History)
10 users (show)

Fixed In Version: gnome-shell-3.10.3-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-26 00:29:51 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 722690 None None None Never

Description Robert Hancock 2014-01-18 22:10:19 UTC
Version-Release number of selected component (if applicable):
0:3.10.3-1.fc20

How reproducible:
Every time

Steps to Reproduce: 
1.Enable "Icons on desktop" in gnome-tweak-tool (Advanced Settings)
2.Hit Alt-Tab. The Files icon is displayed in the Alt-Tab icon list even though no file window is open. (This is a regression from 0:3.10.2.1-3.fc20)
3.If you Alt-Tab to that icon and hit Alt-` to display the open windows, gnome-shell crashes.

Actual results:
Files icon not displayed in icon list

Expected results:
Files icon displayed in list, crashes gnome-shell if Alt-` is pressed

Additional info:
See comment 29 in bug 1012844 for ABRT report of crash. (Marked by ABRT as a duplicate of a clutter bug, but comments in that bug suggest the root cause is generally caused by gnome-shell.)

Comment 1 Didier G 2014-01-19 15:39:37 UTC
If "Enable Icons on desktop" is set using gnome-tweak-tool, "Files" entry is also displayed in gnome-shell top menu even if files manager is not opened.

Comment 2 Heiko Adams 2014-01-23 16:49:58 UTC
Same problem here and this also happens if you've got conky running in the background.

Comment 3 Florian Müllner 2014-01-23 20:48:21 UTC
*** Bug 1057278 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2014-01-23 21:41:12 UTC
gnome-shell-3.10.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gnome-shell-3.10.3-2.fc20

Comment 5 Didier G 2014-01-23 22:08:49 UTC
I just updated to gnome-shell-3.10.3-2.fc20 and problem described in "Comment 1" above still exist if "Enable Icons on desktop" is set using gnome-tweak-tool.

Comment 6 Heiko Adams 2014-01-23 22:16:20 UTC
Did you restart the gnome-shell after the update?

Comment 7 Didier G 2014-01-23 22:23:42 UTC
I rebooted twice and I double-checked installed version:

Name        : gnome-shell
Version     : 3.10.3
Release     : 2.fc20
Architecture: x86_64
Install Date: jeu. 23 janv. 2014 23:04:16 CET

Comment 8 Florian Müllner 2014-01-24 12:53:19 UTC
(In reply to Didier G from comment #5)
> I just updated to gnome-shell-3.10.3-2.fc20 and problem described in
> "Comment 1" above still exists

Indeed, that's not fixed yet. I'll look into fixing this after lunch.

Comment 9 Heiko Adams 2014-01-24 17:51:10 UTC
For the records: The task-switcher and the activities working fine again but there's still an indicator for natutilus on the top-bar if all other windows are minimized.

Comment 10 Florian Müllner 2014-01-24 19:12:39 UTC
(In reply to Heiko Adams from comment #9)
> For the records: The task-switcher and the activities working fine again but
> there's still an indicator for natutilus on the top-bar if all other windows
> are minimized.

Yes, see comment #8 and bug 1057517 (which references an upstream bug with a patch)

Comment 11 Fedora Update System 2014-01-25 02:18:21 UTC
Package gnome-shell-3.10.3-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-3.10.3-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1465/gnome-shell-3.10.3-2.fc20
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2014-01-26 00:29:51 UTC
gnome-shell-3.10.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.