Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1055223 - Safely remove is not working (or broken) as expected in Gnome Disks
Summary: Safely remove is not working (or broken) as expected in Gnome Disks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: udisks2
Version: 7.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Vojtech Trefny
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-19 16:12 UTC by Nrbrtx
Modified: 2018-04-24 07:29 UTC (History)
5 users (show)

Fixed In Version: udisks2-2.7.3-3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 15:43:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 71802 0 None None None Never
GNOME Bugzilla 675542 0 None None None Never
Launchpad 1239087 0 None None None Never
Novell 859374 0 None None None Never
Red Hat Bugzilla 1477736 0 unspecified CLOSED rebase udisks2 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2018:0868 0 None None None 2018-04-10 15:44:11 UTC

Internal Links: 1477736

Description Nrbrtx 2014-01-19 16:12:34 UTC
Description of problem:
In previous versions of gnome-disk-utility (palimpsest) users were able to do a Safely remove of USB-flash or USB-HDD. 
Let's use GNOME Disks 3.0.2 (as in Ubuntu 12.04.3) as example - it uses UDisks v.1 and I'm able to do safely remove (power off) of USB-flash or spin-down USB-HDD. 

Fedora 20 has gnome-disk-utility 3.10.0
UDisks 2.1.2 (built against 2.1.1)
- this version has Safely remove functionality but it seems that is broken.
What I mean by 'broken'?
If I do Safely remove of USB-flash - it works correctly - so after Safely remove LED on flash is off.
If I do Safely remove of USB-HDD - it works incorrectly - it does not spin-down my HDD. 
If I manually to a Safely remove from console with 'udisks --detach /dev/sdX' - LED on my flash is off and my USB-HDD is spinned down. 

So gnome-disks have a bug with Safely remove of USB-HDD.



Version-Release number of selected component (if applicable):
gnome-disk-utility-3.10.0-2.fc20.i686


Steps to Reproduce:
1. Connect USB-HDD to your PC running Fedora 20
2. Do some work on USB-HDD partition(s)
3. Try to do Safely remove of USB-HDD with gnome-disks.

Actual results:
After safely remove USB-HDD is not spinned-down (keep rotating), removed from system (there is no USB-HDD lsusb) and will spin-down only by disconnecting USB-cable.

Expected results:
After Safely remove USB-HDD is spinned-down (not rotating) and may be safely removed.

Additional info:
I understand that USB-mass storage devices may be safely detached from computer after unmount (and sync) and that USB-HDD with SATA interface are hot-pluggable and hot-swappable.
But why safely remove functionality is removed in the newest versions of udisks (and Nautilus, Gnome Disks)?
For me it’s more comfortable to detach USB-flash with switched off LED and spinned-down USB-HDD.

The only one working method for safe detaching of USB-device is to call “udisks --detach /dev/sdXN”, but it does not user-friendly and modern GNU/Linux distros does not have udisks v.1 pre-installed (if I remember correctly - Fedora 20, OpenSuSe 12.3, may be others).

Recently I have brought external USB 3.0 HDD (Western Digital My Passport Ultra 2 TB), it has WD Utilities for Windows.
This WD Utilities has special option (in windows tray) for doing Safely remove of the HDD.
How it works? It spins HDD down, switch off the LED and suggests to detach USB cable after that.
So WD, the 1st HDD manufacturer spins-down their HDD before unplugging (it seems that Ejecting unmounted drive it is not enough for them).
Safely remove for this HDD is working as expected on Ubuntu 12.04.3 too (in both Nautilus and palimpsest).

Comment 1 Fedora Admin XMLRPC Client 2014-02-17 15:36:49 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Nrbrtx 2014-04-28 09:24:39 UTC
The bug exists in Red Hat ____Enterprise___ Linux Workstation 7.0 (Maipo).

Bug can be fixed by upgrading udisks to version 2.1.3 (see commits http://cgit.freedesktop.org/udisks/commit/?id=fcdd8f48b6ac9b1b6da82fdf5f59230fc2ea6feb and http://cgit.freedesktop.org/udisks/commit/?id=a54c2fa14c522487a78828d4a9dfd89f916a3576).

Comment 4 RHEL Program Management 2014-05-06 05:48:37 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 David King 2015-05-15 11:04:43 UTC
This bug is in udisks2 according to the upstream bug reports, and should be fixed in versions 2.1.3 and above.

Comment 6 Vratislav Podzimek 2017-09-12 11:39:34 UTC
This should be resolved by the rebase of udisks2 (BZ #1477736)

Comment 9 Bohdan Milar 2018-01-17 11:30:55 UTC
Tested with udisks2-2.7.3-4.el7.x86_64.
Test done on x86_64 (bare metal) only because of the need to physically connect a device to it.
Test passed.

Comment 12 errata-xmlrpc 2018-04-10 15:43:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0868


Note You need to log in before you can comment on or make changes to this bug.