Bug 1055600 - Shortcuts missing from "Send key" menu when started using plugin
Summary: Shortcuts missing from "Send key" menu when started using plugin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Christophe Fergeau
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On: 1181289
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 15:29 UTC by Tomas Jamrisko
Modified: 2016-03-09 20:08 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, shortcuts were missing from the "Send key" menu when virt-viewer was started using the ActiveX plug-in. This occurred because enabling hotkeys required a rebuild of the menu containing the new hotkeys, which was done before parsing the string containing the new hotkeys. This has been fixed and the new shortcuts now properly show in the menu when connecting using the plug-in.
Clone Of:
: 1230602 1230603 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:08:31 UTC
oVirt Team: Spice
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0377 0 normal SHIPPED_LIVE rhevm-spice-client bug fix and enhancement update 2016-03-10 00:39:05 UTC

Description Tomas Jamrisko 2014-01-20 15:29:42 UTC
Description of problem:

Shortcuts that are set using the activex plugin are not automatically set in Send key menu on the first open display.


Version-Release number of selected component (if applicable):
mingw-virt-viewer-0.5.6-18

How reproducible:
Always 

Steps to Reproduce:
1. Connect to guest from windows client using activex plugin

Expected results:
The Send key combinations for shortcuts (such as Shift+F11) should be added to the menu as they are when started using file

Additional info:
Sorry, missed this as activex was not working properly with IE11 at the time of testing...

Comment 1 Marc-Andre Lureau 2014-01-20 15:35:41 UTC
damn, I was sure I verified that bug in last build... hopefully it is working with upstream... anyway, it should easy to figure out again.

Comment 2 Christophe Fergeau 2015-06-11 08:43:20 UTC
Patch sent to the ML: https://www.redhat.com/archives/virt-tools-list/2015-June/msg00135.html

Comment 3 Fabiano Fidêncio 2015-07-13 15:45:39 UTC
Must be fixed by the rebase.

Comment 4 Christophe Fergeau 2015-07-20 08:39:29 UTC
As Pavel pointed out, this is https://git.fedorahosted.org/cgit/virt-viewer.git/commit/?id=21c71767e3849a7f469dc032393c6deaefc1d3df which is not in a virt-viewer release yet, so this is not fixed by the rebase.

Comment 7 Dayle Parker 2016-03-01 00:39:51 UTC
If this bug requires doc text for errata release, please provide draft text in the doc text field in the following format:

 Cause:
 Consequence:
 Fix:
 Result:

Comment 8 Tomas Pelka 2016-03-01 09:26:52 UTC
(In reply to Dayle Parker from comment #7)
> If this bug requires doc text for errata release, please provide draft text
> in the doc text field in the following format:
> 
>  Cause:
>  Consequence:
>  Fix:
>  Result:

I'm sorry Dayle, we as QE are not responsible for filling doc text.

Comment 10 errata-xmlrpc 2016-03-09 20:08:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0377.html


Note You need to log in before you can comment on or make changes to this bug.