Bug 1055670 - yum update rhevh => install new version instead of update
Summary: yum update rhevh => install new version instead of update
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.3.0
Assignee: Fabian Deutsch
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 18:05 UTC by Pavel Stehlik
Modified: 2014-01-20 19:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-20 19:14:24 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Pavel Stehlik 2014-01-20 18:05:50 UTC
Description of problem:
 yum update is installing instead update package. So it endups with 2 RHEVH packages installed.


on TPS machine:

# yum update rhev-hypervisor6
...
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package rhev-hypervisor6.noarch 0:6.5-20140112.0.el6ev will be installed
--> Finished Dependency Resolution
Dependencies Resolved
================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
rhev-hypervisor6 noarch 6.5-20140112.0.el6ev rhel-x86_64-server-6-rhevh 211 M
Transaction Summary
================================================================================
Install 1 Package(s)
Total download size: 211 M
...
Installing : rhev-hypervisor6-6.5-20140112.0.el6ev.noarch 1/1
Verifying : rhev-hypervisor6-6.5-20140112.0.el6ev.noarch 1/1
Installed:
rhev-hypervisor6.noarch 0:6.5-20140112.0.el6ev
Complete!


new : installed : rhev-hypervisor6-6.5-20140112.0.el6ev.noarch
old : installed : rhev-hypervisor6-6.5-20131204.0.3.2.el6_5.noarch



Version-Release number of selected component (if applicable):
rhev-hypervisor6 noarch 6.5-20140112.0.el6ev

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fabian Deutsch 2014-01-20 19:14:24 UTC
This is not a bug.

The feature got requested in bug 863579.

Three RHEV-H versions will be kept around until th eoldest one is replaced.

Just to ensure, vercmp shows that the upgradepath is sane:
$ rpmdev-vercmp \
  rhev-hypervisor6-6.5-20131204.0.3.2.el6_5.noarch \
  rhev-hypervisor6-6.5-20140112.0.el6ev.noarch
rhev-hypervisor6-6.5-20131204.0.3.2.el6_5.noarch
 <
rhev-hypervisor6-6.5-20140112.0.el6ev.noarch


Note You need to log in before you can comment on or make changes to this bug.