Bug 10558 - IPX networking not functioning in 6.2
IPX networking not functioning in 6.2
Status: CLOSED DUPLICATE of bug 10375
Product: Red Hat Linux
Classification: Retired
Component: mars-nwe (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-03 15:11 EDT by Evan Case
Modified: 2014-03-16 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-03 17:39:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evan Case 2000-04-03 15:11:57 EDT
IPX networking doesn't appear to function.
  Here are a few commands, and their various error messages
  (Copied from command line)

  [root@linux /sbin]# ./ipx_interface check eth0 802.2
  ./ipx_interface: socket: Invalid argument

  [root@linux /sbin]# ./ipx_configure --auto_interface=on
  --auto_primary=on
  ./ipx_configure: socket: Invalid argument

  [root@linux bin]# slist
  slist: Server not found (0x8847) in ncp_open

  [root@linux ecase]# ncpmount -S SERVER -U USER -V SYS /novell
  Logging into SERVER as USER
  Password:
  ncpmount: Invalid argument when trying to find SERVER

  I used linuxconf to change the ipx settings from autoprobed to network
  specific.(802.2)
  That didn't work.
  IP networking does work.
  I had installed RH6.1, and was able to use IPX networking, and login to
  netware servers.
Comment 1 Bill Nottingham 2000-04-03 15:13:59 EDT
Do you have the IPX module loaded?
Comment 2 Evan Case 2000-04-03 15:19:59 EDT
Yes. The socket error also appears during startup, in the init section with
green "OK"'s
Comment 3 Evan Case 2000-04-03 17:30:59 EDT
I installed 6.1 + formatted HDD's. IPX works (Slist lists all the netware
servers). When I upgraded (with installer) to 6.2 IPX fails. The socket error
appears right before the "bringing up interface eth0 [ ok ]".
Comment 4 Bill Nottingham 2000-04-03 17:35:59 EDT
add:

'alias net-pf-4 ipx' to /etc/conf.modules.
Comment 5 Bill Nottingham 2000-04-03 17:39:59 EDT
*** This bug has been marked as a duplicate of 10375 ***

Note You need to log in before you can comment on or make changes to this bug.