Bug 10562 - EXCEPTION OCCURED: TRACEBACK INNERMOST LAST
EXCEPTION OCCURED: TRACEBACK INNERMOST LAST
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
: 22357 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-03 15:36 EDT by o0-0o
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-01 09:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description o0-0o 2000-04-03 15:36:18 EDT
During the reading of the packages you select, the install crashes with
an "Exception occurred" : Traceback Innermostlast.  This occurs in much
the same fashion as BUG # 10453.  The install lies on the secondary master
IDE, and it's being installed to /dev/sda1 or the IBM - DDRS - Ultra2 -
Scsi disk, with an ADAPTEC 7890 adapter.  Can't install, have tried all
variables.  Nothing works.  Needs more ananconda work in python.
Comment 1 Michael Fulbright 2000-04-05 15:23:59 EDT
Did you burn a CD from an ISO image?

If so, have you tried the CD on a different system?
Comment 2 o0-0o 2000-04-06 20:11:59 EDT
I didn't install it from the iso?  It's installed off of the secondary master
IDE HDD...  It's not the CD, it's the code.

*Trying to mount the /dev twice or something?*
Comment 3 o0-0o 2000-04-06 20:13:59 EDT
Exception occurred:

Traceback (innermost last)
File "/usr/bin/anaconda", line 342, in? intf.run(todo, test=test)
File "/usr/lib/anaconda/text.py", line 1165, in run rc=apply (Step[1](),
Step[2])

File "/usr/lib/anaconda/textw/packages.py@, line 11, in __cal__
File "/usr/lib/anaconda/todo.py", line 467, in getCompsList self.comps =
self.method.readComps(self.hdlist)

File "/usr/lib/anaconda/image.py", line 8, in readComps  return Component
Set (self.tree + '/Redhat/base/comps', hdlist)

File "/usr/lib/anaconda/comps.py", line 326, in __init__
self.readCompsFile (file, self.packages)

File "/usr/lib/anaconda/comps.py", line 46, in __getItem__ return
self.packages[item]

Key Error: basesystem


*** NOTE: INSTEAD OF BASESYSTEM, MINE SAYS "Key Error: Kernelcfg"
Comment 4 Jay Turner 2000-04-11 13:17:59 EDT
What type of installation are you doing??  If the source files for the installer
lie on an ext2 filesystem and you perform a Workstation installation, then that
partition (with the source files) will get deleted, thus leading to the errors
that you are reporting.  The same can be said for any hard drive-based Server
installation.  We are going to put checks in for these conditions in the next
release.
Comment 5 o0-0o 2000-04-11 15:15:59 EDT
THE INSTALL FAILS WITH THE ERROR NON-DEPENDENT OF F/S ARCH.  EITHER A EXT2,
MSDOS, FAT16, FAT32, OR NTFS ALL EXHIBIT THE SAME BEHAVIOR.  I'M INSTALLING IT
EXACTLY THE SAME AS I'VE DONE A MILLION TIMES WITH 6.1.  RIGHT FROM THE
SECONDARY SLAVE, WHICH IS AN IDE HDD, TO THE /DEV/SDA1 WHICH IS ON AN ADAPTEC
7890 BUS, AND WORKS QUITE WELL.  THIS IS NOTHING TO DO WITH THE PARTITION
GETTING DELETED.  IT'S SOMETHING ELSE.  MAYBE THE PARTITION IS TRYING TO BE
MOUNTED TWICE BY THE CODE, AND THE OTHER CODE DOESN'T LIKE THIS.  THAT'S JUST A
THOUGHT... IT'S THE ONLY THING THAT MAKES SENSE...  ANYWAY, THIS IS SOOOO
SIMILAR TO THE ERROR THE 6.1 STARTED GIVING ME: TRACEBACK INNER...BLAH BLAH.
BY THE WAY, I'M DOING A CUSTOM INSTALLATION SO THE METHODS YOU PRESCRIBE DON'T
CURE THIS PATIENT.
Comment 6 Jay Turner 2000-04-12 07:46:59 EDT
The reason that you are getting similiar errors (stuff like "traceback") is
because the installer is written in Python, and that is the way that Python
reports problems.  The fact that you are getting keyerrors on package names
means that those RPMs are not available in the source partition.  Did you
download the source files to that partition or copy them from a CDROM?  My
recommendation is that you check that those files are not corrupt (by running
'rpm -K' in the source partition)

I am not able to recreate your problem here in the test lab.
Comment 7 Jay Turner 2000-05-01 09:00:59 EDT
Closing bug due to lack of activity.
Comment 8 gsizer 2000-12-15 12:51:23 EST
*** Bug 22357 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.