Bug 1056214 - EJB invocation performance issues due to high allocation counts of useless strings
Summary: EJB invocation performance issues due to high allocation counts of useless st...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB
Version: 6.1.1,6.2.0,6.2.1
Hardware: All
OS: All
medium
medium
Target Milestone: DR0
: EAP 6.3.0
Assignee: David M. Lloyd
QA Contact: Jan Martiska
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 17:14 UTC by David M. Lloyd
Modified: 2014-06-28 15:25 UTC (History)
4 users (show)

(edit)
A performance issue has been addressed in this release of JBoss EAP 6. The issue was caused by `StatefulComponentInstanceInterceptor` which performed a small concatenation in a debug log statement for every invocation. The subsequent extra allocations could cause increased Garbage Collection activity during stateful EJB invocation, leading to higher per-invocation processing overhead. This release of the product has incorporated an upstream patch which resolves this issue and per-invocation overhead is substantially decreased.
Clone Of:
(edit)
Last Closed: 2014-06-28 15:25:19 UTC


Attachments (Terms of Use)

Description David M. Lloyd 2014-01-21 17:14:30 UTC
Description of problem:

Due to a minor bug in the StatefulComponentInstanceInterceptor, a string concatenation is performed for every invocation which causes a substantial amount of GC churn.  The fix is simple and low-risk and has been thoroughly tested upstream.


Version-Release number of selected component (if applicable):

All versions.

How reproducible:

100%

Steps to Reproduce:
1. Process lots of invocations in a tight loop
2. Observe high allocation counts and GC activity
3. ~ fin ~

Actual results:

Useless string construction

Expected results:

No string construction unless log level is set to DEBUG or higher

Additional info:

The upstream version of this fix is here: https://github.com/wildfly/wildfly/commit/a6727c715a9d04c6991

Comment 2 Kabir Khan 2014-01-21 23:09:33 UTC
qa-acked myself since I wanted to clear out as many as possible before going to bed, and the fix is trivial

Comment 3 Jan Martiska 2014-02-17 10:59:03 UTC
Verified in 6.3.0.DR0.

Comment 4 sgilda 2014-05-12 19:35:56 UTC
Changed <literal></literal> tags in Doc Text to ticks (`) to fix Bug 1096865


Note You need to log in before you can comment on or make changes to this bug.