Bug 1056216 - [GSS] (6.3.0) Change initial connection behavior for cluster connection
Summary: [GSS] (6.3.0) Change initial connection behavior for cluster connection
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: HornetQ
Version: 6.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR2
: EAP 6.3.0
Assignee: Justin Bertram
QA Contact: Miroslav Novak
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On: 1057330 1064596
Blocks: 1087632
TreeView+ depends on / blocked
 
Reported: 2014-01-21 17:21 UTC by Justin Bertram
Modified: 2018-12-09 17:26 UTC (History)
6 users (show)

(edit)
If a clustered HornetQ instance lost its connection to other cluster nodes, reconnection attempts could result in an infinite loop. For a static cluster configuration, any initial connect attempt would be attempted infinitely, ignoring the `reconnect-attempts` parameter. For a dynamic cluster configuration, if the node was disconnected between the time it received a notification about the node being part of the cluster topology and the initial connection, reconnection attempts continued infinitely. This issue has been resolved and the clustering logic now uses the `reconnect-attempts` parameter for both the initial connection attempts and reconnection attempts.
Clone Of:
: 1087632 (view as bug list)
(edit)
Last Closed: 2014-08-06 14:36:28 UTC


Attachments (Terms of Use)

Description Justin Bertram 2014-01-21 17:21:03 UTC
Cluster connection bridge should use the "reconnect-attempts" value for both the initial connection attempts and reconnection attempts.

Comment 1 Justin Bertram 2014-01-21 19:25:55 UTC
Fix committed to the 2.3.x branch.  See https://github.com/hornetq/hornetq/commit/8ef706763c784aebc43c1b4aa3dfc309122f5f2d.

Comment 2 Kabir Khan 2014-04-04 14:46:11 UTC
Setting to ON_QA since upgrade should fix this

Comment 3 Miroslav Novak 2014-05-05 14:05:35 UTC
Hi,

do we have a way to reproduce this issue. I did some tries with debugger but without success. Can you help, please?

Thanks,
Mirek

Comment 4 Shaun Appleton 2014-05-05 21:04:22 UTC
It can't easily be produced without a debugger https://issues.jboss.org/browse/HORNETQ-1306 provides the steps.

Comment 5 Miroslav Novak 2014-05-06 08:46:49 UTC
Thanks Shaun! I'll give it a try.

Comment 6 Miroslav Novak 2014-05-06 11:12:44 UTC
Fix is not present in HornetQ tag HornetQ_2_3_18_Final which is in EAP 6.3.0.ER3. (It seems that it was merged just to master but not to 2.3.x branch.)

This fix also requires update of xsd schema so attribute "initial-connect-attempts" can be set in standalone...xml and domain.xml.

Comment 7 Miroslav Novak 2014-05-07 10:27:52 UTC
Ignore my comment above. Attribute "reconnect-attempts" defines initial retry. I've managed to reproduce the issue and don't see the described problem again when "reconnect-attempts" is set to 3 in cluster-connections.


Note You need to log in before you can comment on or make changes to this bug.