This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 105665 - cannot install into 512M partition
cannot install into 512M partition
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Bailey
Mike McLean
:
Depends On:
Blocks: fc-relnotes-blocker
  Show dependency treegraph
 
Reported: 2003-09-26 09:12 EDT by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 13:49:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2003-09-26 09:12:38 EDT
Description of problem:

This may be a documentation problem (RELEASE-NOTES), a package selection problem
(comps), or something else in install.

The RELEASE-NOTES says that a Custom install (minimal) takes 510M of disk space.
 I allocated a 512M partition as / with a spearate swap partition and attempted
to install.  I got a popup indicating the 49M space needed.  There appear to be
fewer "extra" packages in the minimal install than previous releases but it
still exceeds needs more that 510M.
Comment 1 Michael Fulbright 2003-09-26 12:30:15 EDT
We should bump that number up. We normally wait till the package set is more
finalized and adjust the numbers then.
Comment 2 Gene Czarcinski 2003-09-26 13:14:52 EDT
It would really be useful to get the minimal install does smaller.  When
individual package selection was available during install, I was usually able to
trim some stuff out.  I can still do this post install but will need the larger
partition to do the actual install.

This reason for this very small partition is that I have multiple bootable
operating systems on a single hardware system (typically four -- current
production, next/last production, test1, test2) and use a very small system as
an emergency boot as well as system boot selection (the four main systems are
all installed into the partition rather than the MBR.
Comment 3 Michael Fulbright 2003-09-29 11:51:11 EDT
It is possible with the anaconda installer to make a smaller install size.
However the distribution as most people use it needs tools that use Python and
other packages which over time has pushed the size up.  If you look at how the
install options in anaconda are handled in its sources you ought to be able to
construct your own install targets for it.
Comment 4 Gene Czarcinski 2003-09-29 15:55:53 EDT
Suggestion:  instead of calling what is currently called "minimal" change this
to "recommended minimum disk space" and size it around 650MB or 700MB.  That way
it could stay pretty constant for a while and you will not have to worry about
fine tuning things.
Comment 5 Gene Czarcinski 2003-10-30 13:39:24 EST
RELEASE-NOTES still says 510MB
Comment 6 Ed Bailey 2003-10-30 17:00:55 EST
Ah, now I see why I never saw this one -- it wasn't posted against the release
notes, and the developer it was assigned to never let me know about it.

As for your suggestion regarding adding some amount of additional space to the
actual numbers, I don't think that would be a good idea; it's better to state
that this is what the minimum is, and to let the reader determine how much
additional space they require for their data.  Otherwise, we'll just see people
that need a touch more than the "slop" we added, they add whatever they think is
required, and then complain when they have too much free space (don't laugh --
I've seen complaints of that sort)...

I've made the change to the release notes sources; unfortunately it's too late
for the gold release, but I'll see that the updated release notes make it onto
the Fedora Project website.

The numbers the installer gave me (plus a 10MB or .1GB fudge factor) are:

     o Custom Installation (Minimal): 520MB
 
     o Server: 870MB
 
     o Personal Desktop: 1.9GB
 
     o Workstation: 2.4GB
 
     o Custom Installation (Everything): 5.3GB

Thanks for letting me know about this issue...
Comment 7 Gene Czarcinski 2003-10-31 16:50:25 EST
1.  I do not see any bugzilla component called RELEASE-NOTES or I
would have filed this report against it -- I looked and looked again
just now.

2. While to total amount of code to be installed may total around
520MB, I could not get the install to actually occur with less than at
least 600MB.

3.  A similar situation occurs with an Everything install.  I created
a 6.5GB partition thinking that it would be plenty.  But, after the
install, I started getting warning messages that said the partition
was too full.

The installer itself takes some disk space which is why 520MB is not
enough.  On the other hand, you need at least 20% (my estimate) free
space after the install for a system to work.

For myself, I am not worried about these number and am usually ready
to install a couple of times to get things "right".  However, for
newbies, this could be confusing.

Comment 8 Ed Bailey 2003-10-31 21:43:25 EST
1. Sorry, I wasn't being clear in my comments -- there is no release
notes component; bugs should be filed against the name of the RPM in
which the release notes are packaged (which should be called
"fedora-release", but the mid-release change from "redhat-release"
made things a bit trickier, unfortunately).  That said, having an
explicit "release notes" component might not be a bad idea...

2. Interesting -- I did a minimum test install, and the installed size
turned out to be something like 480MB.  Granted, this was done in a
large (multi-GB) pre-existing partition, so any higher transient space
requirement wouldn't have bitten me.  Hmmm, I wonder how I could
capture peak space usage during an install...

3. The challenge here is that two kinds of people can read the release
notes -- newbies, and people with some previous Linux experience.  I
need to give the information in such a way that both types of people
can make the right decisions.  Obviously, this needs some work, as you
are interpreting the numbers as being sufficient for a workable
system, when they are meant to reflect only how much space the
installed bits will take.

Thanks for the additional info...
Comment 9 Brent Fox 2004-03-19 16:31:19 EST
Ed, is this bug still an issue?  I just did a minimal install of
rawhide (FC2 as of 3/19/2004) and a minimal install was 484 MB.
Comment 10 Gene Czarcinski 2004-04-21 06:06:14 EDT
This is still an issue with FC2-T3.

While the amount of space used after the install is complete can be
520M or less, a minimum install cannot be perfomed with only a single
520M partition defined.  Please, try it ... it just will not work. 
The installer needs some extra disk space during the install.  The
implication that I can install into a 520M partition is just not true.

Suggestion:  A satisfactory solution to this would be to add a
statement to the size estimates that "the install process itself needs
an additional (100M? 120M? 140M?) of disk space and that this will be
freed upon completion of the install".


Also, I believe that the space estimate for an everything install
might be a bit low.  I will verify this when I do a fresh install of
FC2-T3.
Comment 11 Ed Bailey 2004-04-21 13:09:38 EDT
Your suggestion in comment #10 has merit; I'll touch base with the
Anaconda people to see if they have some way of determining the
overhead required...
Comment 12 Gene Czarcinski 2004-04-21 15:48:06 EDT
The easiest way to find out may be to allocate a small partition and
try to install.   Keep trying (bumping up the size each time) until
you do install then add a bit to be safe.
Comment 13 Ed Bailey 2004-04-21 16:04:46 EDT
As it so happens, the overhead is due to the need for Anaconda to have
the /Fedora/base/stage2.img file and the equivalent of the contents of
/var/lib/rpm on disk while the installation is taking place.

The size of the fc2t3 stage2.img file is ~72MB.  I have an install
going now to get the /var/lib/rpm size, and will then try an
appropriately-sized partition to test...
Comment 14 Gene Czarcinski 2004-04-21 16:19:50 EDT
OK, but /var/lib/rpm is going to vary depending on haw many packages
are installed.  I suggest you get the two extremes (minimal and
everything), up those numbers a little, and say "size ranges from nnnM
for a minimal install to  mmmM for an Everthing install".  Then add
the info that you give above ... The extra size depeneds on the size
of stage2.img plus the space needed for /var/lib/rpm

I just did a quick check using "du -k" and for a "tailored"
FC1+all_updates, /var/lib/rpm is 58M.  On the other hand, the size of
/var/lib/rpm for a FC2T2+development_updates system is currently 128M
Comment 15 Ed Bailey 2004-05-06 15:52:42 EDT
Ok, here's what I've come up with.  What do you think?

Note
                                                                     
          
The disk space requirements listed below represent the disk space
taken up by Fedora Core 1.92 Test 3 after the installation is
complete. However, additional disk space is required during the
installation to support the installation environment. This additional
disk space corresponds to the size of /Fedora/base/stage2.img (on
CD-ROM 1) plus the size of the files in /var/lib/rpm on the installed
system.
                                                                     
          
In practical terms, this means that as little as an additional 90MB
can be required for a minimal installation, while as much as an
additional 175MB can be required for an "everything" installation.
                                                                     
          
Also keep in mind that additional space will be required for user any
data.
                                                                     
          
Comment 16 Gene Czarcinski 2004-05-07 04:15:41 EDT
That looks good to me.  At least with this folks should not expect to
install into a 520MB partition.

BTW, the estimated size for an everything install seems a bit low to
me.  I am seeing about 6.5GB for i386 and 7.1GB for x86_64 everything
installs ... which (to me) translates into a 10GB partition being
about the minimum for an everything install.

You might also mention in you notes that the system needs at least 5%
free space to work or it gripes a lot (email to root).
Comment 17 Ed Bailey 2004-05-07 13:49:46 EDT
Thanks for your feedback on the new wording.

Your point concerning having sufficient free space is a good one; I'll
add that.

Thanks again...

Note You need to log in before you can comment on or make changes to this bug.