Bug 105677 - up2date spews errors -- missing logo file
up2date spews errors -- missing logo file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-26 10:43 EDT by Chris Ricker
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 15:42:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-09-26 10:43:33 EDT
Over and over again:

(up2date:28258): libglade-WARNING **: Error loading image: Failed to open file
'/usr/share/pixmaps/redhat/shadowman-round-48.png': No such file or directory
 
(up2date:28258): libglade-WARNING **: could not convert string to type
`GdkPixbuf' for property `logo'
Comment 1 Adrian Likins 2003-09-29 15:22:35 EDT
hmm, odd. I'll take a look.

(and yes, this comment is mostly just a test of `bugtool`)
Comment 2 Dave Habben 2003-10-02 16:30:11 EDT
It looks like redhat-logos changed the location of this file.

This is off of a Red Hat 9 system
# rpm -qf /usr/share/pixmaps/redhat/shadowman-round-48.png
redhat-logos-1.1.12-1

redhat-logos-1.1.17-1:
# rpm -ql redhat-logos | grep shadowman
/usr/share/firstboot/pixmaps/shadowman-round-48.png

So which is it going to be?
/usr/share/pixmaps/redhat/shadowman-round-48.png
/usr/share/firstboot/pixmaps/shadowman-round-48.png
Comment 3 Dave Habben 2003-10-02 16:35:12 EDT
Shouldn't this also mean that up2date should have a dependancy on redhat-logos?
Comment 4 Bill Nottingham 2003-10-02 17:09:58 EDT
Well, redhat-logos itself is going away.
Comment 5 Dave Habben 2003-10-10 12:34:08 EDT
Fixed as of:
fedora-logos-1.1.19-1

# rpm -ql fedora-logos | grep redhat/shadowman
/usr/share/pixmaps/redhat/shadowman-round-48.png

This should probably be marked as RAWHIDE/CLOSED
Comment 6 Chris Ricker 2003-10-10 13:02:52 EDT
No, it won't be permanently fixed until up2date requires fedora-logos

You're right that the errors are gone once fedora-logos is installed from
rawhide, though
Comment 7 Bill Nottingham 2003-10-21 17:00:09 EDT
up2date can just require the exact file.

Note You need to log in before you can comment on or make changes to this bug.