Bug 105709 - debuginfo link and debuginfo file not correct for vmlinux
debuginfo link and debuginfo file not correct for vmlinux
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
RC3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-26 15:00 EDT by William Cohen
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 21:03:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Cohen 2003-09-26 15:00:42 EDT
Description of problem:

debuginfo file for /boot/vmlinux-2.4.22-20.1.2024.2.36.nptlsmp is not in the
correct place. The .debug file should be in /usr/lib/debug/boot. It is placed in 
/usr/lib/debug/lib/modules/2.4.22-1.2075.nptlsmp/vmlinux.debug. The debuginfo
file should have the same basename and end up as
/usr/lib/debug/boot/vmlinux-2.4.22-20.1.2024.2.36.nptlsmp.debug. It looks like
the debug information is being extracted before the vmlinux is placed in the
correct place.

OProfile needs the debuginfo to map kernel samples back to source code.

Version-Release number of selected component (if applicable):

kernel-2.4.22-1.2075.nptl
kernel-debuginfo-2.4.22-1.2075.nptl

Note You need to log in before you can comment on or make changes to this bug.