Bug 105720 - anaconda crashes when installing from USB storage device
Summary: anaconda crashes when installing from USB storage device
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-09-26 20:12 UTC by Trond Eivind Glomsrød
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 19:13:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug file saved to floppy by anaconda (50.39 KB, text/plain)
2003-09-26 20:14 UTC, Trond Eivind Glomsrød
no flags Details

Description Trond Eivind Glomsrød 2003-09-26 20:12:42 UTC
Anaconda crashes and burns when arriving at the hard drive partitioning when
doing a hard drive install from my external USB/firewire drive (250 GB maxtor).

Comment 1 Trond Eivind Glomsrød 2003-09-26 20:14:02 UTC
Created attachment 94767 [details]
debug file saved to floppy by anaconda

please make it possible to save to something else soon, floppies are hard to
find.

Comment 2 Jeremy Katz 2003-09-29 21:11:08 UTC
Fixed in CVS.

The dump is also in /tmp/anacdump.txt and you have scp to be able to get it off
the box.  

Comment 3 David Wilson 2003-10-12 02:51:10 UTC
One of my systems did not even get to the partitioning stage. 
 
Attempted to install from an external 120GB drive in a USB2.0 enclosure to a 
SCSI hard drive on an IBM ServeRAID controller. Anaconda crashed just after it 
started up X. 
 
Probing for video card:  ATI Mach64 3D Rage IIC 
Probing for monitor type:  Unknown monitor 
Probing for mouse type:  Generic - Wheel Mouse (PS/2) 
Attempting to start native X server 
Waiting for X server to start...log located in /tmp/X.log 
1...2...3...4...5.... X server started successfully. 
Traceback (most recent call last): 
  File "/usr/bin/anaconda", line 996, in ? 
    rootPath) 
  File "/usr/bin/anaconda/harddrive.py", line 208, in __init__ 
    self.mountDirectory() 
  File "/usr/bin/anaconda/harddrive.py", line 89, in mountDirectory 
    readOnly = 1); 
  File "/usr/bin/anaconda/isys.py", line 162, in mount 
    rc = _isys.mount(fstype, device, location, readOnly, bindMount, remount) 
SystemError: (22, 'Invalid argument') 
install exited abnormally 
 
I suspect that this may be because usb-storage is treated as a scsi 
controller. I booted from floppy, it loaded usb-storage, I selected language 
and keyboard layout, it loaded isp and usb-storage (again), I selected loading 
files from hard drive (/dev/sda1). Given that my SCSI hard drive (internal) 
should be sda after the O/S is installed having the USB drive load first will 
be a problem. 
 
I then moved the USB drive to a non-SCSI system and got the same results as 
Trond - anaconda crashed at partitioning stage. 

Comment 4 David Wilson 2003-10-28 04:40:52 UTC
test3 gets past partitioning stage on my non-SCSI system but fails during 
install of openoffice (claiming corrupted image or out of space [certainly not 
that - I doubled disk allocation and got same error]). Need to do more testing 
to see what is happening - will try from IDE instead of USB to confirm not USB 
problem. 

Comment 5 Rahul Sundaram 2005-08-15 16:38:50 UTC
ping

Comment 6 Jeremy Katz 2005-09-21 19:13:42 UTC
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further information, feel free to
add to the report and reopen.


Note You need to log in before you can comment on or make changes to this bug.