Bug 105748 - redhat-config-network don't configure correctly the adsl connection
redhat-config-network don't configure correctly the adsl connection
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2003-09-26 18:05 EDT by Claudio
Modified: 2014-03-16 22:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-30 16:34:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
ls -l of /etc/sysconfig/network-scripts/ (2.21 KB, text/plain)
2003-09-28 23:48 EDT, Andre Robatino
no flags Details
ppp0 (417 bytes, text/plain)
2003-09-29 00:09 EDT, Andre Robatino
no flags Details
ppp1 (385 bytes, text/plain)
2003-09-29 00:10 EDT, Andre Robatino
no flags Details
eth0 (74 bytes, text/plain)
2003-09-29 00:11 EDT, Andre Robatino
no flags Details
ppp0 (426 bytes, text/plain)
2003-10-07 19:05 EDT, Claudio
no flags Details
eth0 (77 bytes, text/plain)
2003-10-07 19:05 EDT, Claudio
no flags Details

  None (edit)
Description Claudio 2003-09-26 18:05:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
i make this steps:
1. run redhat-config-network to set ip address of eth0 via dialup 
2. run internet druid 
3. run redhat-config-network to set start connection on boot
4. from redhat-config-network i start the connection
5. seemingly the gui report all ok
6. start mozilla but i can't browse the net
7. disable firewall and i try again to browse but i can't
8. restart the pc to see if the connection start on boot
9. start mozilla but i can't browse
10. run ifconfig and i see only "lo" and "eth0" but not "ppp0"
10. run /sbin/adsl-setup adsl-start
11. now i can write this report

sorry for my english.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Additional info:
Comment 1 Andre Robatino 2003-09-28 12:40:06 EDT
  I think I'm experiencing the same thing.  After using redhat-config-network to
create a new xDSL connection, and activating it, the connection came up but I
had no DNS.  I found that there were two valid IP addresses in
/etc/ppp/resolv.conf, but they were not copied automatically to
/etc/resolv.conf.  Upon copying them manually under the DNS tab in the GUI, I
now have working DNS (though this shouldn't be necessary).  Also, the GUI shows
eth0 still inactive, even though it is activated when ppp0 comes up
(/sbin/ifconfig confirms that eth0 is in fact active).  Also, though I have ppp0
configured to come up automatically at boot time, this doesn't happen.  I have
to start it manually with redhat-config-network.  It appears that /sbin/ifup is
expecting a file with the name ifcfg-ppp0, but there is no such file in the
system; however there _is_ a file with the name ifcfg-Verizon_DSL (Verizon_DSL
is the nickname I gave ppp0 in the GUI).  The different packages obviously
aren't cooperating.
Comment 2 Bill Nottingham 2003-09-28 23:40:47 EDT
What do you have in /etc/sysconfig/network-scripts/ifcfg-*?
Comment 3 Andre Robatino 2003-09-28 23:48:21 EDT
Created attachment 94807 [details]
ls -l of /etc/sysconfig/network-scripts/
Comment 4 Bill Nottingham 2003-09-29 00:03:41 EDT
Sorry, please attach the /etc/sysconfig/network-scripts/ifcfg-* files. :)
Comment 5 Andre Robatino 2003-09-29 00:09:45 EDT
Created attachment 94808 [details]
Comment 6 Andre Robatino 2003-09-29 00:10:53 EDT
Created attachment 94809 [details]
Comment 7 Andre Robatino 2003-09-29 00:11:50 EDT
Created attachment 94810 [details]
Comment 8 Andre Robatino 2003-09-29 00:13:58 EDT
  I just noticed that in redhat-config-network, it allows selecting a nickname
for eth0, but "eth0" is entered by default.  When creating ppp0 (Verizon_DSL)
and ppp1 (Verizon_Dialup), the nickname box was empty to begin with (and a
nonempty entry seems to be required).  If redhat-config-network was supposed to
create symbolic links to ifcfg-ppp0 and ifcfg-ppp1, resp., it didn't happen. 
For that matter, I don't see why the files aren't named that to begin with,
since one doesn't see the actual names in the GUI.
  I didn't attach ifcfg-lo since the date indicates that it's generic.
Comment 9 Andre Robatino 2003-09-29 13:32:56 EDT
  P.S.  At shutdown, same problem - shutdown of ppp0 fails since it can't find
the nonexistent file ifcfg-ppp0.
Comment 10 Kristian Harms 2003-10-02 15:49:41 EDT
I see the same issues as described by Robatino in Fedora 0.94.

As regards the config files named by connection nickname and not ppp0, simply
renaming the files will make ifup and ifdown not complain about missing
configuration files, allowing ppp0 to be activated at boot or otherwise from
outside redhat-config-network.  In my case, i did:  mv ifcfg-Telenor ifcfg-ppp0.
Comment 11 Ngo Than 2003-10-02 17:05:58 EDT
Harald, it seems it's the same problem in #105785
Comment 12 Claudio 2003-10-07 19:05:16 EDT
Created attachment 95003 [details]

Comment 13 Claudio 2003-10-07 19:05:54 EDT
Created attachment 95004 [details]

Comment 14 Andre Robatino 2003-10-09 15:01:27 EDT
  Applied today's (2003-10-9) updates including redhat-config-network.  I
deleted and recreated my network interfaces to test.  No change in any of the
problems reported above.  I made symlinks from ifcfg-ppp0 and ifcfg-ppp1 to the
nickname ifcfg files so the connection can come up at boot time.  Another tiny
issue:  When booting up in text mode, I see two messages "bringing up interface
ppp0", the first succeeds, the second fails (since the connection is already
up).  This was there before, I neglected to report it, it appears harmless.
Comment 15 Andre Robatino 2003-10-26 14:56:35 EST
  As of test3 with redhat-config-network-1.3.8-1 and initscripts-7.41-1, all the
above problems still exist.  I reported the problem with the ethernet interface
being shown as inactive under bug #107816 (redhat-config-network), and the
problem with the ifcfg-* filename mismatch as bug #108033 under
redhat-config-network (I'm pretty sure that's where it belongs).  I'm not sure
where the problem with having to manually enter the DNS addresses belongs, but
it's still there.
Comment 16 Chan Min Wai 2004-02-02 12:29:40 EST
dcmwai|triage->duplicate 97845
Comment 17 Bill Nottingham 2004-02-02 12:50:14 EST
97845 is  a PPP bug, not a ADSL bug.
Comment 18 Chan Min Wai 2004-02-02 13:04:49 EST
However it is an initscript bug ...
Comment 19 Bill Nottingham 2004-02-02 13:08:57 EST
Yes, but they aren't the same bug, AFAICT, hence, they're not duplicates.
Comment 20 Chan Min Wai 2004-02-03 03:02:02 EST
Ok My fault.
shouldn't this be solved yet?
Comment 21 Bill Nottingham 2005-09-30 16:34:32 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of

Please try to reproduce this on a current release, such as Fedora Core 4. If the
issue persists, please open a new issue. I think this is solved by now, looking
at the other referenced bugs.

Note You need to log in before you can comment on or make changes to this bug.