Bug 108033 - interface doesn't come up automatically at boot time
interface doesn't come up automatically at boot time
Status: CLOSED DUPLICATE of bug 109601
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-26 14:49 EST by Andre Robatino
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2003-10-26 14:49:23 EST
Description of problem:
  When creating a new xDSL or dialup interface, redhat-config-network creates
the ifcfg file named after the nickname (for example, an xDSL interface
corresponding to ppp0 with the nickname Verizon_DSL gets named
ifcfg-Verizon_DSL, not ifcfg-ppp0).  As I recall, redhat-config-network used to
create a symlink pointing from one file name to the other (I don't remember if
it was ifcfg-ppp0 -> ifcfg-Verizon_DSL or ifcfg-Verizon_DSL -> ifcfg-ppp0).  It
no longer does this.  The problem is that when the connection is configured to
come up at boot time, there is an error message complaining about the
nonexistence of the file ifcfg-ppp0.
(There is a corresponding error message on shutdown.)  In order to make it work,
I have to manually create the symlink in /etc/sysconfig/network-scripts. 
However, if I use redhat-config-network to change my settings and then save
them, it deletes my symlinks!  So I have to manually recreate them each time.  I
reported this under bug #105748, but apparently it's gotten lost in the shuffle.
  By the way, I can bring up the connection _manually_ with
redhat-config-network itself (without the symlinks), but this is a pain.

Version-Release number of selected component (if applicable):
1.3.8-1

How reproducible:
always

Steps to Reproduce:
1.  Create a new xDSL interface (with a nickname different from ppp0) and
configure it to come up at boot time.
2.  Reboot.
    
Actual results:
Error message complaining about the nonexistence of ifcfg-ppp0.  Connection
doesn't come up.
Corresponding error message on shutdown.

Expected results:
xDSL interface should come up automatically.  Also should go down automatically
on shutdown.

Additional info:
  This has been broken since test2.  I think it's a mistake for
redhat-config-network to create ifcfg-* files named after nicknames.  The GUI
lets people avoid working with the files directly anyway, and the new names
break other things.  I think that to avoid breaking other things, if there has
to be a file named after the nickname, the right way is for
redhat-config-network to name the actual file ifcfg-ppp0 (for example), and then
automatically create a symlink from ifcfg-Verizon_DSL (for example) to ifcfg-ppp0.
Comment 1 Bill Nottingham 2003-11-10 12:07:21 EST

*** This bug has been marked as a duplicate of 109601 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:59:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.