Bug 105785 - ISDN is not working with neat
Summary: ISDN is not working with neat
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 106259 (view as bug list)
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-09-27 15:15 UTC by Inger Karin Haarbye
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-29 16:02:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/isdncard (104 bytes, text/plain)
2003-10-02 07:05 UTC, Inger Karin Haarbye
no flags Details
My /etc/sysconfig/network-scripts/ifcfg-eth0 (248 bytes, text/plain)
2003-10-02 07:07 UTC, Inger Karin Haarbye
no flags Details
/etc/sysconfig/network-scripts/ifcfg-ippp0 - I renamed this from ifcfg-OnlineTrafikk (name of my "connection") (431 bytes, text/plain)
2003-10-02 07:09 UTC, Inger Karin Haarbye
no flags Details
/etc/sysconfig/network-scripts/ifcfg-lo (Don't know if you really needed this one) (254 bytes, text/plain)
2003-10-02 07:10 UTC, Inger Karin Haarbye
no flags Details

Description Inger Karin Haarbye 2003-09-27 15:15:59 UTC
Description of problem:

I tried to set up My ISDN-card with neat. I have Teles 16.3c PnP card (isapnp).
I got no option to choose IRQ and IO.
Still - I configured my card and connection to ISP, but was not able to activate
the card:

/sbin/ifup: konfigurasjon for ippp0 ikke funnet.
Bruk: ifup <enhetsnavn>

(configuration for ippp0 not found).

Version-Release number of selected component (if applicable):

redhat-config-network-1.3.6-1

How reproducible:

Every time.

Steps to Reproduce:
1. Configure ISDN-card
2. Configure connection to ISP - and save.
3. Try to activate the connection
    
Actual results:

Error message:
/sbin/ifup: konfigurasjon for ippp0 ikke funnet.
Bruk: ifup <enhetsnavn>

Expected results:


Additional info:

Comment 1 Bill Nottingham 2003-10-01 20:29:14 UTC
Please attach your /etc/sysconfig/network-scripts/ifcfg-*

Comment 2 Ngo Than 2003-10-01 21:41:13 UTC
and please attach your /etc/sysconfig/isdncard

Comment 3 Inger Karin Haarbye 2003-10-02 07:05:46 UTC
Created attachment 94870 [details]
/etc/sysconfig/isdncard

Comment 4 Inger Karin Haarbye 2003-10-02 07:07:13 UTC
Created attachment 94871 [details]
My /etc/sysconfig/network-scripts/ifcfg-eth0

Comment 5 Inger Karin Haarbye 2003-10-02 07:09:19 UTC
Created attachment 94872 [details]
/etc/sysconfig/network-scripts/ifcfg-ippp0 - I renamed this from ifcfg-OnlineTrafikk (name of my "connection")

Comment 6 Inger Karin Haarbye 2003-10-02 07:10:56 UTC
Created attachment 94873 [details]
/etc/sysconfig/network-scripts/ifcfg-lo (Don't know if you really needed this one)

Comment 7 Bill Nottingham 2003-10-02 14:52:02 UTC
So, it works once it was renamed, yes?

Were you invoking 'ifup ippp0' by hand, or was something else invoking it?

Comment 8 Inger Karin Haarbye 2003-10-02 17:05:50 UTC
After I renamed ifcfg-OnlineTrafikk ti ifcfg-ippp0 I used "neat" to activate, 
but disconnecting did not work. 
 
I think bugzilla has some problems. Something is wrong here! Earlier info is 
missing from this bug: 
 
------- Additional Comments From harald@redhat.com  2003-09-30 07:28 ------- 
try and give your dialup account the nickname ippp0 
 
 
------- Additional Comments From haarbye@online.no  2003-09-30 17:04 ------- 
Yes, it works if I rename to ifcfg-ippp0   
(but I get some trouble with disconnecting, sort of same problem I think:   
Cant deactivate, use: ifdown <enhetsnavn>. Disconnects OK with /sbin/hangup  
ippp0).  
  
 

Comment 9 Bill Nottingham 2003-10-02 18:54:56 UTC
If neat activation fails with the config that neat wrote, that's a neat bug, not
initscripts.

However, you're saying with it renamed to ippp0, that startup works, but
shutdown fails?  'ifdown ippp0' fails to find the config?

Comment 10 Ngo Than 2003-10-02 19:57:28 UTC
it seems that initscripts does not work if the nickname is not the same device!

Comment 11 Bill Nottingham 2003-10-02 20:02:39 UTC
Hm, the regular ppp stuff works now, the ippp stuff might need tweaked.

Comment 12 Inger Karin Haarbye 2003-10-02 23:24:18 UTC
You asked: 
 
"However, you're saying with it renamed to ippp0, that startup works, but 
shutdown fails?  'ifdown ippp0' fails to find the config?"  
  
I renamed ifcfg-OnlineTrafikk to ifcfg-ippp0 - and now I can activate ISDN 
with neat. I still can't deactivate ISDN with neat, I get the message "Can't 
deactivate OnlineTrafikk" - "use: ifdown <enhetsnavn>". 
  
ifdown ippp0 (or isdnctrl hangup ippp0) works.. 
 
I think neat tries to do a "ifup ippp0" when I activate the connection and  
"ifdown OnlineTrafikk" when I deactivate (And when I renamed 
ifcfg-OnlineTrafikk to ifcfg-ippp0 neat will not find ifcfg-OnlineTrafikk).  
 
If I copy ifcfg-OnlineTrafikk to ifcfg-ippp0 (instead of rename) neat can 
activate and deactivate the ISDN-connection (but I didn't get back my default 
gateway to eth0). 

Comment 13 Bill Nottingham 2003-10-03 02:17:32 UTC
OK, assigning to redhat-config-network for at least the last problem you've
mentioned.

Do ifup <config name> and ifdown <config name> work in both cases (the config
named Online-Trafikk or the config named ippp0)?


Comment 14 Inger Karin Haarbye 2003-10-05 08:48:08 UTC
Yes ifup/ifdown ippp0 works and ifup/ifdown OnlineTrafikk works. (the 
configfiles are exact the same...) but "isdnctrl OnlineTrafikk" will not work: 
 
root@opuntia root]# ifup ippp0 
[root@opuntia root]# isdnctrl dial ippp0 
Dialing of ippp0 triggered 
[root@opuntia root]# ifdown ippp0 
[root@opuntia root]# ifup OnlineTrafikk 
[root@opuntia root]# isdnctrl dial OnlineTrafikk 
Interface name must not exceed 8 characters! 
[root@opuntia root]# ifdown OnlineTrafikk 
[root@opuntia root]# 

Comment 15 Harald Hoyer 2003-10-06 09:52:51 UTC
*** Bug 106259 has been marked as a duplicate of this bug. ***

Comment 16 Ngo Than 2003-10-22 15:39:50 UTC
i have added support of Nickname for ISDN in initscript and
redhat-config-network. It should fix this problem.

Notice:
If you use nickname like ifcfg-OnlineTrafikk, you have to start your ISDN
connection with:
  ifup OnlineTrafikk
  isdnctrl dial ippp0

It's easier if you start it from redhat-config-network.

initscript-7.39-1 and redhat-config-network-1.3.7-2 has this fix.
Many thanks for your report.

Comment 17 Inger Karin Haarbye 2003-10-26 12:47:45 UTC
I don't use theese "nicknames", I use "neat" if it is working. Sadly, it is a 
very long time since "neat" has done its job with isdn. (bug #82241 #85365 
#100677 and this bug).  
Actually I have used ADSL the last couple of years, I only use isdn for test 
purposes. In my country it is still many users with isdn-connection, so this 
is why I put me through this pain. 
"neat" is still not working with Fedora Core 0.95 (exception occured). After 
upgrading to initscripts-7.41-1 and redhat-config-network-1.3.8-1 from 
rawhide, no exception errors occurred, but activating the connection is not 
working. Just nothing happens. 
I hope that Fedora Core (as Red Hat 9.0) will not be released with broken 
neat/ISDN.  
 
  

Comment 18 Ngo Than 2003-10-29 16:02:13 UTC
I assume you still have old isdn4k-utils on your machine.

Please upgrade to isdn4k-utils-3.2-5.p1, which should be available in rawhide.
It will fix this problem. I have tested it here and it works fine.





Note You need to log in before you can comment on or make changes to this bug.