Bug 105804 - php-manual not working due to changes in httpd-manual conf
php-manual not working due to changes in httpd-manual conf
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: php (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
: 107384 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-27 16:37 EDT by Need Real Name
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.3.3-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-30 04:20:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-09-27 16:37:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; .NET CLR 
1.1.4322)

Description of problem:
Hi people:
I was testing the new packages form rawhide, and since the manual 
configuration form httpd has changed, this cause that te php-manual don't 
display ok, as a solution to this I recommend to put the modules manuals out 
of httpd-manual directory, for example in /var/www/modmanuals/ and in this 
directory put all the modules manuals, ex for 
php /var/www/modmanuals/mod_php4 , because if everybody change the format of 
their manual the configuration manual for httpd will be really ugly. So in 
this way then we create a module-manual.conf file in httpd conf.d with the 
configuration parameters for that manual, for example in the case of php a 
file like this
php-manual.conf in conf.d directory of httpd

Alias /mod_php4 "/var/www/modmanuals/mod_php4"

<Directory "/var/www/modmanuals/mod_php4">
    Options Indexes FollowSymLinks MultiViews IncludesNoExec
    AddOutputFilter Includes html
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

And then modify the php spec file to reflect the new manual location
and add the php-manual.conf.
                                   Regards Aliet

Version-Release number of selected component (if applicable):
php-4.3.3-2

How reproducible:
Always

Steps to Reproduce:
1.Instal php-manual rpm
2.
3.
    

Additional info:
Comment 1 Joe Orton 2003-10-20 05:13:19 EDT
*** Bug 107384 has been marked as a duplicate of this bug. ***
Comment 2 Joe Orton 2003-10-30 04:20:54 EST
This is no longer a bug, since php-manual has been removed.

- remove manual: up-to-date manual sources are no longer DFSG-free;
  it's too big; it's on the web anyway; #91292, #105804, #107384

Note You need to log in before you can comment on or make changes to this bug.