Bug 107384 - php-manual contains invalid html
Summary: php-manual contains invalid html
Status: CLOSED DUPLICATE of bug 105804
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-17 16:42 UTC by Brian Brock
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Brock 2003-10-17 16:42:02 UTC
php-manual-4.3.3-4 contains HTML that is invalid, and is subsequently not
parseable by apache httpd.

Here's a sample of the broken HTML, note the line breaks that occur in the
middle of html elements:

<HTML
><HEAD
><TITLE
>PHP Manual</TITLE
><META
NAME="GENERATOR"
CONTENT="Modular DocBook HTML Stylesheet Version 1.73
"><LINK
REL="NEXT"
TITLE="Preface"
HREF="preface.html"><META
HTTP-EQUIV="Content-type"
CONTENT="text/html; charset=ISO-8859-1"></HEAD



httpd-2.0.47-8 was the apache httpd tested, always results in the following in
/var/log/httpd/error_log:
---
[error] [client 127.0.0.1] Syntax error in type map, no ':' in
/var/www/manual/mod/mod_php4/index.html for header <html
 
---

I suspect this may be a bug in the version of DocBook (or an SGML parser) used
during generation of the html in php-manual, or it may be a bug in the use of
one of those tools.

Comment 1 Joe Orton 2003-10-20 09:13:17 UTC
httpd is parsing the HTML as a typemap, it's actually a config error. 

I'm removing the PHP manual for the next version, which will resolve this issue.

*** This bug has been marked as a duplicate of 105804 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:59:14 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.