Bug 105851 - Epiphany rpm contains epiphany-1.0.pc but not /usr/include/epiphany-1.0 headers
Summary: Epiphany rpm contains epiphany-1.0.pc but not /usr/include/epiphany-1.0 headers
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: epiphany   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Marco Pesenti Gritti
QA Contact:
URL:
Whiteboard:
Keywords:
: 117767 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-28 12:49 UTC by Nicolas PENINGUY
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 10:25:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SPEC file for Epiphany to include epiphany-devel (8.29 KB, text/plain)
2004-10-09 23:09 UTC, Ryan Skadberg
no flags Details

Description Nicolas PENINGUY 2003-09-28 12:49:12 UTC
Description of problem:

I tried to build Epiphany plugins (ephy-extenstions, see
http://savannah.nongnu.org/files/?group=ephyplugins )

configure successfuly finds /usr/lib/pkgconfig/epiphany-1.0.pc,
but this files references /usr/include/epiphany-1.0, which is
not included in the rpm.

I think headers should be included, or the epiphany-1.0.pc
removed.

Comment 1 Christopher Blizzard 2003-09-29 21:16:32 UTC
Wow, does this need a -devel rpm?

Comment 2 Nicolas PENINGUY 2003-09-29 21:43:00 UTC
Well, you're the boss, but that would be cool. :-)


Comment 3 Marco Pesenti Gritti 2004-10-08 14:46:41 UTC
*** Bug 117767 has been marked as a duplicate of this bug. ***

Comment 4 Ryan Skadberg 2004-10-09 23:09:31 UTC
Created attachment 104975 [details]
SPEC file for Epiphany to include epiphany-devel

Comment 5 Ryan Skadberg 2004-10-09 23:10:55 UTC
This is still the case.  I've attached a SPEC which makes an epiphany
devel.  Also, in the SPEC, I moved the pkgconfig file to the devel
RPM.  It would be real nice if epiphany was built like this, as people
like to install epiphany extensions (It would also be nice if
epiphany-extensions were included in FC )


Comment 6 Marco Pesenti Gritti 2004-10-11 13:55:11 UTC
Please attach a diff. You can create it using:

diff -u oldspec newspec


Note You need to log in before you can comment on or make changes to this bug.