Bug 1058765 - Review Request: mono-cecil - Library to generate and inspect programs and libraries in the ECMA CIL form
Summary: Review Request: mono-cecil - Library to generate and inspect programs and lib...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Will Benton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1032883
TreeView+ depends on / blocked
 
Reported: 2014-01-28 13:51 UTC by Miro Hrončok
Modified: 2015-01-06 06:16 UTC (History)
4 users (show)

Fixed In Version: OpenTK-1.1-1.4c.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-06 06:16:48 UTC
willb: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Miro Hrončok 2014-01-28 13:51:20 UTC
Spec URL: https://raw.github.com/hroncok/SPECS/master/mono-cecil.spec
SRPM URL: http://kojipkgs.fedoraproject.org/work/tasks/2934/6462934/mono-cecil-0.9.5-1.20131105git8425de4.fc21.src.rpm

Description:
Cecil is a library written by Jb Evain to generate and inspect programs and
libraries in the ECMA CIL format. It has full support for generics, and support
some debugging symbol format.

In simple English, with Cecil, you can load existing managed assemblies, browse
all the contained types, modify them on the fly and save back to the disk the
modified assembly.

Today it is used by the Mono Debugger, the bug-finding and compliance checking
tool Gendarme, MoMA, DB4O, as well as many other tools.

Fedora Account System Username: churchyard

Comment 1 Will Benton 2014-02-27 17:50:05 UTC
Thanks for your hard work packaging this project!  There are a few
minor things to address before I can approve the review.

Issues and notes:

* Thanks for using a commit SHA to specify your source archive
  location.

* Please replace the hard-coded /usr/lib/mono with a macro; you may
  define %{monodir} as /usr/lib/mono in this spec, but I am planning
  to get a clarification to the Mono guidelines that has an official
  macro (see https://fedorahosted.org/fpc/ticket/395).

* You probably should require mono-core since (1) mono-core is required
  to use mono-cecil and (2) you place files in /usr/lib/mono/gac,
  which mono-core owns.  These conditions are listed in 
  https://fedoraproject.org/wiki/Packaging:Guidelines#File_and_Directory_Ownership

  Note that Cecil's functional dependency on mono-core is captured by
  its (automatically-generated) Requires at the moment, but
  the explicit Requires: mono-core is to ensure that you comply by
  the file and directory ownership guidelines even if the assemblies
  you depend on move to another package than the gac directory in the
  future.  It also appears to be common practice among mono libraries to
  explicitly depend on mono-core.

* Please file an issue upstream to get a license file included in the
  source tarball.

* It appears that this package includes tests.  Please either run them
  (in %check) or justify why the tests can't be run in koji with a
  specfile comment.


Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[-]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "MIT/X11 (BSD like)", "Unknown or generated". 76 files have unknown
     license. Detailed output of licensecheck in /home/wibenton/devel/review
     /mono-cecil/licensecheck.txt
[x]: Package does not own files or directories owned by other packages.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[-]: Package uses nothing in %doc for runtime.
[!]: Package consistently uses macros (instead of hard-coded directory names).

- see explanation above

[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[!]: Requires correct, justified where necessary.

- see explanation above

[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
[!]: Package complies to the Packaging Guidelines

- except as already mentioned

[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Each %files section contains %defattr if rpm < 4.4
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[!]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[!]: %check is present and all tests pass.

- please add %check or justify why the tests can't run

[x]: Packages should try to preserve timestamps of original installed files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present (not strictly required in GL).
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Fully versioned dependency in subpackages if applicable.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.


Rpmlint
-------
Checking: mono-cecil-0.9.5-1.20131105git8425de4.fc21.noarch.rpm
          mono-cecil-0.9.5-1.20131105git8425de4.fc21.src.rpm
mono-cecil.noarch: W: incoherent-version-in-changelog 0.9.5-1 ['0.9.5-1.20131105git8425de4.fc21', '0.9.5-1.20131105git8425de4']
mono-cecil.noarch: W: only-non-binary-in-usr-lib
mono-cecil.src:33: E: hardcoded-library-path in %{buildroot}/usr/lib/mono/gac/
mono-cecil.src:35: E: hardcoded-library-path in %{buildroot}/usr/lib
mono-cecil.src:36: E: hardcoded-library-path in %{buildroot}/usr/lib
mono-cecil.src:37: E: hardcoded-library-path in %{buildroot}/usr/lib
mono-cecil.src:38: E: hardcoded-library-path in %{buildroot}/usr/lib
mono-cecil.src:43: E: hardcoded-library-path in /usr/lib/mono/gac/Mono.Cecil*
mono-cecil.src:44: E: hardcoded-library-path in /usr/lib/mono/Mono.Cecil*
2 packages and 0 specfiles checked; 7 errors, 2 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint mono-cecil
mono-cecil.noarch: W: incoherent-version-in-changelog 0.9.5-1 ['0.9.5-1.20131105git8425de4.fc21', '0.9.5-1.20131105git8425de4']
mono-cecil.noarch: W: only-non-binary-in-usr-lib
1 packages and 0 specfiles checked; 0 errors, 2 warnings.
# echo 'rpmlint-done:'



Requires
--------
mono-cecil (rpmlib, GLIBC filtered):
    mono(Mono.Cecil)
    mono(System)
    mono(System.Core)
    mono(mscorlib)



Provides
--------
mono-cecil:
    mono(Mono.Cecil)
    mono(Mono.Cecil.Mdb)
    mono(Mono.Cecil.Pdb)
    mono(Mono.Cecil.Rocks)
    mono-cecil



Source checksums
----------------
https://github.com/jbevain/cecil/archive/8425de4db6a6e120154ced991f1ebc8d4d79dfb5/mono-cecil-0.9.5-8425de4.tar.gz :
  CHECKSUM(SHA256) this package     : f205b6b0d7efcf0358bc9a4d12a7a0debaa16061708dd8789dc55ad651291552
  CHECKSUM(SHA256) upstream package : f205b6b0d7efcf0358bc9a4d12a7a0debaa16061708dd8789dc55ad651291552


Generated by fedora-review 0.5.0 (920221d) last change: 2013-08-30
Command line :/usr/bin/fedora-review --rpm-spec -n /home/wibenton/rpmbuild/SRPMS/mono-cecil-0.9.5-1.20131105git8425de4.fc19.src.rpm -m fedora-rawhide-x86_64
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Shell-api
Disabled plugins: Java, C/C++, Python, SugarActivity, Perl, R, PHP, Ruby
Disabled flags: EPEL5, EXARCH, DISTTAG

Comment 2 Miro Hrončok 2014-02-27 19:03:30 UTC
Thanks for the review.

I've pushed new spec that fixes your issues (no new SRPM yet):

https://raw.github.com/hroncok/SPECS/master/mono-cecil.spec

I tried to run the tests by nunit, but so far I have no success, could you give me a hand with it please? I have no idea, how should I invoke it in the right way.

Comment 3 Will Benton 2014-02-27 19:45:32 UTC
(One more thing:  there is a bundled nunit installation in Test/; please remove this during %prep.)

Comment 4 Will Benton 2014-02-27 19:51:16 UTC
(In reply to Miro Hrončok from comment #2)
> Thanks for the review.
> 
> I've pushed new spec that fixes your issues (no new SRPM yet):
> 
> https://raw.github.com/hroncok/SPECS/master/mono-cecil.spec
> 
> I tried to run the tests by nunit, but so far I have no success, could you
> give me a hand with it please? I have no idea, how should I invoke it in the
> right way.

I've taken a look at this; unfortunately, I'm not a Mono expert and can find no other packages that use nunit (or nant, which depends on nunit) in their builds!  It looks like you'll need to compile the projects in Test and rocks/Test before running any tests, but actually running the tests from the given configuration file (I used "nunit-console Mono.Cecil.nunit") fails because some symbol files and libraries aren't where they are expected.

If you could reach out to upstream and ask how they run tests as part of their CI, that would probably be helpful.  If it's going to be a lot of work to get the tests running, though, I won't hold up the review just because of a missing %check.

Comment 5 Jeffrey C. Ollie 2014-10-03 14:50:26 UTC
Any news on getting this finished up?  Until this gets into Fedora and OpenTK gets updated RepetierHost won't work.

Comment 6 Miro Hrončok 2014-10-07 10:59:29 UTC
Well, I was not able to run the tests. So I would go for no %check. However, it seems a lot of commits had passed since February, so I'll check whatever version RepetierHost needs and test that again.

Comment 7 Miro Hrončok 2014-10-25 19:05:48 UTC
So once again, after a long time:

Spec URL: https://raw.githubusercontent.com/hroncok/SPECS/c3a1defc8d7625aab20e36721688ae6dbff3e633/mono-cecil.spec
SRPM URL: https://churchyard.fedorapeople.org/SRPMS/mono-cecil-0.9.5-3.20140924git6d1b7d0.fc20.src.rpm

It's updated. I definitely don't run test, because I was not bale to do that sorry.

Will, still doing the review?

Thanks

Comment 8 Miro Hrončok 2014-10-25 19:06:10 UTC
s/bale/able/

Comment 9 Miro Hrončok 2014-10-25 19:59:40 UTC
Spec URL: https://raw.githubusercontent.com/hroncok/SPECS/master/mono-cecil.spec
SRPM URL: https://churchyard.fedorapeople.org/SRPMS/mono-cecil-0.9.5-3.20140924git6d1b7d0.fc20.src.rpm

After removing bundled nunit, I had to patch the sln file not to build the tests

Comment 10 Will Benton 2014-11-05 20:16:48 UTC
Thanks for the updates, Miro.  You've addressed all of my concerns from the review and the package looks fine now.  (We're still waiting on a clarification on the Mono guidelines, unfortunately!)

Comment 11 Miro Hrončok 2014-11-06 09:21:58 UTC
Thanks a lot, Will.

Comment 12 Miro Hrončok 2014-11-06 09:23:21 UTC
New Package SCM Request
=======================
Package Name: mono-cecil
Short Description: Library to generate and inspect programs and libraries in the ECMA CIL form 
Upstream URL: http://www.mono-project.com/Cecil
Owners: churchyard
Branches: f21

Comment 13 Gwyn Ciesla 2014-11-06 12:55:10 UTC
Git done (by process-git-requests).

Comment 14 Fedora Update System 2014-12-27 14:05:28 UTC
mono-cecil-0.9.5-3.20140924git6d1b7d0.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/mono-cecil-0.9.5-3.20140924git6d1b7d0.fc21

Comment 15 Fedora Update System 2014-12-27 16:58:16 UTC
OpenTK-1.1-1.4c.fc21,mono-cecil-0.9.5-3.20140924git6d1b7d0.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/OpenTK-1.1-1.4c.fc21,mono-cecil-0.9.5-3.20140924git6d1b7d0.fc21

Comment 16 Fedora Update System 2014-12-29 10:04:33 UTC
Package OpenTK-1.1-1.4c.fc21, mono-cecil-0.9.5-3.20140924git6d1b7d0.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing OpenTK-1.1-1.4c.fc21 mono-cecil-0.9.5-3.20140924git6d1b7d0.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-17689/OpenTK-1.1-1.4c.fc21,mono-cecil-0.9.5-3.20140924git6d1b7d0.fc21
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2015-01-06 06:16:48 UTC
OpenTK-1.1-1.4c.fc21, mono-cecil-0.9.5-3.20140924git6d1b7d0.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.