Bug 105888 - old rpm-spec-mode.el in emacs
Summary: old rpm-spec-mode.el in emacs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-09-29 01:11 UTC by Dams
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 14:54:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GNU Emacs compatibility patch for rpm-spec-mode.el. (975 bytes, patch)
2003-10-28 00:59 UTC, Dams
no flags Details | Diff

Description Dams 2003-09-29 01:11:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Galeon/1.3.9

Description of problem:
The rpm-spec-mode.el has been updated for Xemacs but not for GNU Emacs. Though
both of them are not up-to-date. Could you please grab the latest
rpm-spec-mode.el ? It should (must?) be the same file for both Xemacs and GNU
Emacs. The latest version fix a bug for the add-change-log-entry function when
release tag contains a macro. This is really annoying me :)

The fix should be available here :
http://livna.org/~anvil/fedora/Emacs/rpm-spec-mode-field-value.patch and should
work on both GNU Emacs and Xemacs.

Version-Release number of selected component (if applicable):
emacs-el-21.3-6 xemacs-sumo-el-20030831-1

How reproducible:
Always

Steps to Reproduce:
1/ Add a macro (%blah with a %define blah foo above) in the release tag.
2/ try C-c C-e
3/ Look at the changelog entry.


Additional info:
System is stock severn2.

Comment 1 Jens Petersen 2003-10-27 14:17:32 UTC
I don't see anything newer at <http://www.tihlde.org/~stigb/rpm-spec-mode.el>.

Perhaps the version in xemacs cvs is newer?

Comment 2 Ville Skyttä 2003-10-27 23:59:29 UTC
Jens is correct (and the "upstream" URL is correct too).  I have committed some
updates to the one in XEmacs and forwarded everything upstream.  I haven't
received any feedback from Stig, apparently he hasn't applied the fixes yet. 
Probably his version lags far behind the one in XEmacs packages.

I don't personally use GNU Emacs so I can't comment more on the version included
in it.  About time to start using XEmacs instead, Dams? :)))

Comment 3 Ville Skyttä 2003-10-28 00:01:27 UTC
Oh, and as you probably know, the "XEmacs version" is available at
http://cvs.xemacs.org/viewcvs.cgi/XEmacs/packages/xemacs-packages/prog-modes/rpm-spec-mode.el

Comment 4 Dams 2003-10-28 00:59:46 UTC
Created attachment 95538 [details]
GNU Emacs compatibility patch for rpm-spec-mode.el.

This patch, applied to the xemacs version, revert some changes and bring the
GNU Emacs compatibility back.

Comment 5 Dams 2003-10-28 01:07:29 UTC
Thanks Ville but i will keep the little GNU :)

The version included in GNU emacs package is quite the same than the one
provided with shrike.

Stig has been idle for quite some times now : some of the changes has been sent
more than 6 months ago. I suggest we use the xemacs rpm-spec-mode.el version +
the little patch i attached. 

Jens, what do you think ? 

Comment 6 Jens Petersen 2004-01-15 02:09:11 UTC
Sounds fine to me.

It should get updated in emacs-21.3-8.

Comment 7 Jens Petersen 2004-01-15 04:47:09 UTC
Ville, are you going to apply Dams' field value patch to
xemacs pkg cvs? :)

Comment 8 Ville Skyttä 2004-01-15 16:51:39 UTC
It's already in XEmacs CVS and packages since June...

2003-06-27  Damien Nadé  <anvil@livna.org>

	* rpm-spec-mode.el (rpm-spec-field-value): Fix macro expansion.



Note You need to log in before you can comment on or make changes to this bug.