Bug 105938 - Graphical Installer Glitch on Dell Inspiron 7500
Summary: Graphical Installer Glitch on Dell Inspiron 7500
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-09-29 17:50 UTC by Thomas J. Baker
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 18:42:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas J. Baker 2003-09-29 17:50:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Galeon/1.3.9

Description of problem:
The graphical installer doesn't come up correctly with either severn beta. The
xserver starts but only about 1/4 of an inch of video is displayed on the left
hand side of the screen. The laptop in question has a 1400x1050 display and a
ATI Rage Mobility graphics card. After doing a text install, the generated
default X config works fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot a severn install disc 
2. Proceed with the graphical install
3.
    

Actual Results:  Only the left most 1/4 inch of video is displayed, and it looks
normal.

Expected Results:  The normal graphical redhat install is displayed.

Additional info:

Comment 1 Michael Fulbright 2003-10-03 18:47:32 UTC
If you start with 'resolution=1400x1050' does it come up in the graphical
installer ok?

Comment 2 Thomas J. Baker 2003-10-03 19:04:15 UTC
What happened to my previous updates? I already answered these questions. I'll
re-upload them when I'm not traveling. Basically, at 1400x1050, the screen just
came up grey.

Comment 3 Michael Fulbright 2003-10-03 20:00:24 UTC
I was referring to the install boot time option like:

linux resolution=1400x1050

which makes the graphical installer try to use 1400x1050 instead of 800x600.

Comment 4 Thomas J. Baker 2003-10-15 14:33:03 UTC
OK, here are the comments from my previous entries that were lost:

------- Additional Comments From tjb@unh.edu  2003-10-01 06:38 -------It looks
like the X server only starts once. The console says Probing mouse, Attempting
to start xserver, waiting for X server, 1 2 3 4 5 xserver started successfully.
It doesn't look like it tries twice.

When supplying the resolution=1400x1050 on the command line, when X comes up it
just shows a blank grey screen.


Back to today, October 15th:

I just tried it last night with test3 and the same problems occur. I saw a post
that about nofb so I tried it and everything worked fine that way. So "linux
nofb" makes the graphical installer work fine with test3 anaconda.




Comment 5 Jeremy Katz 2003-10-16 18:42:05 UTC
Okay, that's going to have to be the workaround, then.  Basically, it's a video
BIOS bug in that it can't handle running the native X resolution after going
into the vga16fb mode.


Note You need to log in before you can comment on or make changes to this bug.