Bug 105972 - MrProject won't launch - relocation error
MrProject won't launch - relocation error
Status: CLOSED DUPLICATE of bug 103614
Product: Fedora
Classification: Fedora
Component: mrproject (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-29 22:25 EDT by Kurt Maute
Modified: 2013-04-02 00:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Maute 2003-09-29 22:25:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
On a fresh install of Fedora Core test2, launched MrProject from the menu and it
did nothing.  Then launched from a command line and got:

mrproject: relocation error: /usr/lib/mrproject/views/libresources-view.so: 
undefined symbol:  mrp_project_get_properties

This could be an incompatibility between the version of mrproject you have and
the version of libmrproject included in the distribution.  They are:
mrproject-0.9-5
libmrproject-0.10pre-4

...which is an odd mix.  They are normally in synch.

MrProject v0.10 has recently been released.  If I get a moment, I'll try
upgrading both mrproject and libmrproject to that and see how it goes.

Version-Release number of selected component (if applicable):
mrproject-0.9-5, libmrproject-0.10pre-4

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core Severn test2
2. Open a terminal window
3. $ mrproject
    

Actual Results:  mrproject: relocation error:
/usr/lib/mrproject/views/libresources-view.so:  undefined symbol: 
mrp_project_get_properties

Expected Results:  It should have launched the application.

Additional info:
Comment 1 Bill Nottingham 2003-09-29 22:46:07 EDT

*** This bug has been marked as a duplicate of 103614 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.