Bug 1060200 - sosreport --build doesn't work
Summary: sosreport --build doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sos
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Bryn M. Reeves
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1060198
TreeView+ depends on / blocked
 
Reported: 2014-01-31 12:46 UTC by Sandro Bonazzola
Modified: 2014-04-02 09:17 UTC (History)
3 users (show)

Fixed In Version: sos-3.0-23.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-02 09:17:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Sandro Bonazzola 2014-01-31 12:46:10 UTC
Description of problem:
# sosreport --build
Usage: sosreport [options]

sosreport: error: no such option: --build

Version-Release number of selected component (if applicable):
sos-3.0-3.fc20.noarch

How reproducible:
100%

Steps to Reproduce:
1.sosreport --build
2.
3.

Actual results:
# sosreport --build
Usage: sosreport [options]

sosreport: error: no such option: --build

Expected results:
sosreport --build should work as stated in man page:
       --build
              Do not archive copied data. Causes sosreport to leave an uncompressed archive as a temporary file or directory tree.

Comment 1 Bryn M. Reeves 2014-01-31 14:39:00 UTC
Thanks. This was fixed upstream:

commit b65606177be6210f3f0501e5689cdbb107e0f2f7
Author: Bryn M. Reeves <bmr@redhat.com>
Date:   Tue Nov 5 16:07:23 2013 +0000

    Restore --build command line option
    
    Releases of sos prior to 3.0 included the '--build' option to
    disable creation of a compressed archive and to leave the
    temporary build tree in place. This was removed with the
    reorganisation of the archive classes to support in-line
    archiving. Since all supported policies are now using an archive
    that derives from FileCacheArchive (commit 0178d5f) the option
    can be re-introduced.
    
    Archive classes that do not accumulate files in a temporary
    directory will return the path to the in-progress archive file.
    
    Signed-off-by: Bryn M. Reeves <bmr@redhat.com>

I'll update the f20 package to include the post-3.0 changes.

Comment 2 Sandro Bonazzola 2014-02-04 10:00:27 UTC
(In reply to Bryn M. Reeves from comment #1)

> I'll update the f20 package to include the post-3.0 changes.

Thanks! I'll wait for it.

Comment 3 Fedora Update System 2014-03-31 16:13:48 UTC
sos-3.0-23.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sos-3.0-23.fc20

Comment 4 lnie 2014-04-01 02:56:10 UTC
sos-3.0-23.fc20  works

Comment 5 Fedora Update System 2014-04-02 09:17:11 UTC
sos-3.0-23.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.