Bug 10603 - NCD X-terminals confuse alphanum "1" for "backspace"
Summary: NCD X-terminals confuse alphanum "1" for "backspace"
Status: CLOSED DUPLICATE of bug 11245
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-05 18:47 UTC by Rolf Fokkens
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-30 17:02:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rolf Fokkens 2000-04-05 18:47:11 UTC
Since I upgraded to RedHat 6.2 NCD X-terminals (Explora 700) respond
confusing when pressing the alphanumerical "1" key: it results in a
backspace. I tried this on two machines that upgraded from 6.1 to 6.2.

During XDMCP login (XDM, GDM, or KDM) there's no problem, but once username
and password are accepted, every "1" entered results in a "backspace"

This can not be reproduced by "X -query .." from a RedHat 6.1 machine. Nor
is the problem there when doing "DISPLAY=ncd:0 xterm", the problem is only
there once the window manager has started (KDE, GNOME or Afterstep).

Comment 1 Rolf Fokkens 2000-04-14 06:19:59 UTC
The problem can be solved by using xmodmap, which might cause the problem as
well, if some .rc file changes keymappings during login:

On NCD terminals xmodmap shows "keycode 22 = 1 exclam" when using RedHat 6.1.
With RedHat 6.2 xmodmap shows "keycode 22 = BackSpace", which causes the
problem.

"keycode 22 = BackSpace" only applies to local X servers on PC hardware, but not
in general.

Comment 2 Rolf Fokkens 2000-04-14 20:04:59 UTC
Solution: get rid of /etc/X11/xinit/Xmodmap.

Comment 3 Preston Brown 2000-05-30 17:02:59 UTC
*** This bug has been marked as a duplicate of 11245 ***


Note You need to log in before you can comment on or make changes to this bug.