Bug 11245 - xinitrc-2.9 contains a new default Xmodmap that breaks some X-terminals
Summary: xinitrc-2.9 contains a new default Xmodmap that breaks some X-terminals
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinitrc   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
: 10603 11355 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-05 14:55 UTC by vigna
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-30 16:35:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description vigna 2000-05-05 14:55:33 UTC
The xinitrc-2.9 package contains a new default
Xmodmap that has a single assignment---keycode 22 gets assigned
Backspace instead of tilde/grave as usual. As a result, our >20
Tektronix terminals suddenly started to do backspace instead of tilde.
I do not know if this applies to other kind of terminals. The file
was nonexistent as of xinitrc-2.3, but I haven't checked inbetween
versions.

Note that the default X keyboard works flawlessly with Tektronix
terminals. The presence of that Xmodmap file is, at least, debatable.

Comment 1 Preston Brown 2000-05-30 16:35:59 UTC
agreed, we are reverting the inclusion of this file in an xinitrc errata this
week.

Comment 2 Preston Brown 2000-05-30 17:01:59 UTC
*** Bug 10603 has been marked as a duplicate of this bug. ***

Comment 3 Preston Brown 2000-05-30 18:29:59 UTC
*** Bug 11355 has been marked as a duplicate of this bug. ***

Comment 4 js 2000-06-08 06:58:40 UTC
Looking forward to this fix. In the meantime, after reading /etc/termcap line 
477-481, I found out that I temporary can use ^I instead of TAB, which should 
solve the STILL UNRESOLVED bug in bug report 11355.


Note You need to log in before you can comment on or make changes to this bug.