Bug 106050 - (IT_53880_42163_53883) need to convert Japanese manpages to UTF-8
need to convert Japanese manpages to UTF-8
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
: i18n
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-02 05:19 EDT by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-28 21:05:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
man page for rpm package in UTF-8 (ja and ko) (15.72 KB, application/octet-stream)
2003-12-10 19:59 EST, Lawrence Lim
no flags Details

  None (edit)
Description Akira TAGOH 2003-10-02 05:19:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.2.1) Gecko/20030303

Description of problem:
Since we have decided to use UTF-8 locale, we can't look at EUC-JP manpages. so
basically it needs to be converted to UTF-8.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.LANG=ja_JP.UTF-8 man rpm
2.
3.
    

Actual Results:  more warnings are output, and manpages is not readable.

Expected Results:  no warnings and readable.

Additional info:

I'm refiling this due to bugzilla issue.
Comment 1 Lawrence Lim 2003-12-10 19:59:55 EST
Created attachment 96464 [details]
man page for rpm package in UTF-8 (ja and ko)

1) iconv -f EUC-JP -t UTF-8 rpm.8 > rpm.8.ja_JP.UTF-8
2) iconv -f EUC-KR -t UTF-8 rpm.8 > rpm.8.ko_KR.UTF-8
Comment 2 Jeff Johnson 2003-12-26 13:14:23 EST
Fixed in CVS, should be in rpm-4.2.2-0.8 and later.
Comment 3 John Flanagan 2004-05-12 00:27:16 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-098.html
Comment 5 Eido Inoue 2004-06-25 10:34:09 EDT
while the man pages really should be converted to UTF-8, it should be
noted that the current version of nroff in FC2 will auto-convert
EUC-JP man pages to UTF-8. So when man is upgraded, you won't see the
breakage anymore.

But this functionality is for legacy app compatibility-- the core man
pages should be in the default encoding for all locales: UTF-8.
Comment 6 Jeff Johnson 2004-06-25 16:53:11 EDT
This issue is/was fixed, rpm-4.2.2-0.14 is in RHEL 3QU2 and the
fix is in fc3 and RHEL4.

Now you want the change reverted? Please confirm, I'm confused.
Comment 7 Akira TAGOH 2004-06-27 06:26:44 EDT
Comment #5: on FC2 or later you are right. but this issue happens on
RHEL3. we hadn't done UTF-8 migration yet on RHEL3. and we don't
support UTF-8 on CJK locales for RHEL3. we are missing a lot to do it
on RHEL3.
if this issue can be fixed in man and/or groff, I have no objection.
but please note that the packages other than rpm has the manpages of
the legacy encoding on RHEL3. and the manpages on RHEL3 should be
shown as the legacy encodings like EUC-JP/EUC-KR/GB18030/Big5.
we have 2 versions of the package(man/groff or rpm) for RHEL3 and
others anyway.
Comment 10 Leon Ho 2004-11-23 07:40:35 EST
The summary does not reflect the current problem in RHEL3 at all
(Customers wanted the manpages encoding change from UTF-8 to eucJP
because we were using native encoding in RHEL3).

The original problem was for FC2 and this is already resolved.

Fuchi-san, I think it is better to post a new bug so that Jeff will
have more clear on the problem and the situation. What do you think?
Comment 11 Leon Ho 2004-11-28 21:05:53 EST
bug 138434 is open for the RHEL3 man page issue now. Closing this
because the initial problem is fixed on FC2.

Note You need to log in before you can comment on or make changes to this bug.