Bug 106051 - need to convert Japanese manpages to UTF-8
Summary: need to convert Japanese manpages to UTF-8
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-10-02 09:23 UTC by Akira TAGOH
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: 4.0.3-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 16:28:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Akira TAGOH 2003-10-02 09:23:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.2.1) Gecko/20030303

Description of problem:
Since we have decided to use UTF-8 locale, we can't look at EUC-JP manpages. so
basically it needs to be converted to UTF-8.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.LANG=ja_JP.UTF-8 man 5 shadow
2.
3.
    

Actual Results:  more warnings are output, and manpages is not readable.

Expected Results:  no warnings and readable.

Additional info:

I'm refiling this due to bugzilla issue.

Comment 1 Nalin Dahyabhai 2003-10-22 16:28:26 UTC
Fixing in 4.0.3-13.  Is there a systematic way of doing this sort of thing which
is preferred over one-off solutions like the one used this time?

Comment 2 Akira TAGOH 2003-10-24 13:02:19 UTC
Well, actually all manpages should has any information what encoding it is
using. e.g. .encoding UTF-8. and basically groff should converts it according to
that and current locale. but no such rules right now. so what we can do now is
just using iconv or something.


Note You need to log in before you can comment on or make changes to this bug.