Bug 106078 - Volume Control throws exception when opened
Volume Control throws exception when opened
Status: CLOSED DUPLICATE of bug 104276
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-02 11:36 EDT by Norbert Roma
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norbert Roma 2003-10-02 11:36:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
After right-clicking on the volume control icon in the panel I get the Volume
Control GUI and an error message saying:

"An error occurred while loading or saving configuration information for
gnome-volume-control. Some of your configuration settings may not work properly."

The "details" button provides the following message:
---------------------------------------------
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-ESS_Maestro_2E-1/Vol  ": ` ' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-ESS_Maestro_2E-1/Pcm  ": ` ' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-ESS_Maestro_2E-1/Spkr ": ` ' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-ESS_Maestro_2E-1/Line ": ` ' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-ESS_Maestro_2E-1/Mic  ": ` ' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-ESS_Maestro_2E-1/CD   ": ` ' is an invalid
character in key/directory names
---------------------------------------------

The hardware browser identifies my sound card as "ES1978 Maestro 2E" and dmesg
says the following about it:

maestro: Configuring ESS Maestro 2E found at IO 0xEC00 IRQ 5
maestro:  subvendor id: 0x80581033
maestro: not attempting power management.
maestro: AC97 Codec detected: v: 0x574d4c00 caps: 0x140 pwr: 0xf
maestro: 1 channels configured.
maestro: version 0.15 time 14:48:15 Sep 22 2003
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE]
parport0: irq 7 detected

This is a NEC Versa SX laptop.


Version-Release number of selected component (if applicable):
gnome-media-2.3.7-1

How reproducible:
Always

Steps to Reproduce:
1.Add volume control to the panel
2.Rigth-click on the volume control icon and select "Open Volume Control"
3. Click on the "details" button when the error message dialog appears


Actual Results:  The volume control actually works, but I did not investigate if
there is any impediment to full functionality

Expected Results:  There should be no error messages

Additional info:

I do have intermittent issues running realplayer and keeping esd from quitting,
but I don't know if it's realted.
Comment 1 Bill Nottingham 2003-10-02 15:59:18 EDT

*** This bug has been marked as a duplicate of 104276 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.