Bug 104276 - gnome-volume-control can't save preferences, making all sounds silent
gnome-volume-control can't save preferences, making all sounds silent
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-media (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
: 105629 105802 106078 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-11 18:34 EDT by Chris Ricker
Modified: 2015-01-07 19:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-08 20:32:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-09-11 18:34:19 EDT
gnome-media-2.3.7-1

When I start gnome-volume-control, I get the warning that:

An error occurred while loading or saving configuration information for
gnome-volume-control. Some of your configuration settings may not work properly.

If I hit details, I'm told that:

Bad key or directory name:
 "/apps/gnome-volume-control/OSS-C-Media_PCI-1/Vol  ": ` ' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-C-Media_PCI-1/Pcm  ": ` ' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-C-Media_PCI-1/Spkr ": ` ' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-C-Media_PCI-1/Line ": ` ' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-C-Media_PCI-1/Mic  ": ` ' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-C-Media_PCI-1/CD   ": ` ' is an invalid
character in key/directory names


As a result of this, my system is completely silent regardless of how I adjust
the volume in g-v-c
Comment 1 Chris Ricker 2003-09-12 10:50:59 EDT
Hmm, at least this morning volume adjustment seems to be working now, even
though I still get the errors and such -- now it seems it's more of a cosmetic
problem than a functional one. Not sure why it wasn't working at all yesterday.
Only change was a logout and log back in to gnome....
Comment 2 Bill Nottingham 2003-09-26 01:56:57 EDT
*** Bug 105629 has been marked as a duplicate of this bug. ***
Comment 3 Dax Kelson 2003-09-26 02:44:51 EDT
doh! Chris beat me to this bug. It helps that he's been running rawhide for
awhile... :)
Comment 4 Manmathan Kumarathurai 2003-09-26 09:05:34 EDT
In can confirm the above problem in my system containing gnome-media-2.3.7-1.
Comment 5 Christopher M. Hickman 2003-09-26 13:22:06 EDT
I'm having the same problem, as as stated, it seems to "work", just "complain"
for some reason. I get the same error.

Chris
Comment 6 Elton Woo 2003-09-27 15:50:08 EDT
recurrent in Fedora Core (see Bug 105802).
Comment 7 Bill Nottingham 2003-09-29 01:24:56 EDT
*** Bug 105802 has been marked as a duplicate of this bug. ***
Comment 8 John Thacker 2003-09-29 02:05:46 EDT
As I noted in <A
HREF="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=105802">Bug
105802</A>, this has been fixed upstream since gnome-media-2.3.8.  See 

http://bugzilla.gnome.org/show_bug.cgi?id=119979

I downloaded and installed gnome-media-2.4.0, using the SPEC from the 2.3.7-1
package, and the problem went away.  Should be a simple matter of pushing an
upgraded package.
Comment 9 Bill Nottingham 2003-10-02 15:59:24 EDT
*** Bug 106078 has been marked as a duplicate of this bug. ***
Comment 10 Dave Habben 2003-10-08 11:35:03 EDT
This should be fixed with the latest updates:
gnome-media-2.4.0-1

This should probably be marked as RAWHIDE/CLOSED

Note You need to log in before you can comment on or make changes to this bug.