Bug 106103 - r-c-xfree86 fails completely with ATI Radeon 9800
Summary: r-c-xfree86 fails completely with ATI Radeon 9800
Status: CLOSED DUPLICATE of bug 106501
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-xfree86   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-02 19:36 UTC by Chris Ricker
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2003-10-02 19:36:04 UTC
Dell Dimension 4600 with a Radeon 9800 128MB ram

During install, anaconda tries to use the radeon driver, fails, and falls back
to vesa (Bug #105962). After install, X does not work at all. When r-c-xfree86
runs, it fails because it tries to use the radeon driver, and that has
resolvable Chip Id issues (Bug #106102)

If Bug #106102 is fixed, r-c-xfree86 will presumably Just Work. However, if Bug
#106102 isn't fixed, r-c-xfree86 should still be able to generate a working vesa
configuration, and currently it fails when falling back to that.

Comment 1 Need Real Name 2003-10-15 15:43:52 UTC
I can't get it to run at all with a radeon 9500 / dual or single monitor setup

[root@grover root]# /usr/bin/redhat-config-xfree86
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 398, in __init__
    key, value = string.split(card.driver, ":")
ValueError: unpack list of wrong size
[root@grover root]#


Comment 2 Thomas Gordon 2003-10-17 07:32:35 UTC
I get the same error with test3 up2date as of 2003-10-16 using XFree86-4.3.0-40.
 redhat-config-xfree86 doesn't work.

Using radeon 9500 NP.  My drivers apear to be loading fine.

Comment 3 Warren Togami 2003-10-22 07:00:56 UTC
This issue is a showstopper for my Radeon 9200 128MB, where
redhat-config-xfree86 is completely unable to configure the card.  Manually
editing XF86Config however works perfectly, with full DRI acceleration.

The above traceback is exactly the error that I see.

Comment 4 Warren Togami 2003-10-22 07:07:52 UTC
Would you agree this is the same problem as Bug 106501?  If so, please close
DUPLICATE because that other report has more details.

Comment 5 Warren Togami 2003-10-23 22:25:56 UTC
Read Bug 106501 and download Brent's new redhat-config-xfree86.  Re-open this
bug if that package does not solve the problem for you.

*** This bug has been marked as a duplicate of 106501 ***

Comment 6 Thomas Gordon 2003-10-31 09:49:34 UTC
I'm using all the latest updates posted on Oct 30, 2k3.  Not sure if this is
related.

Been using ATI Binary on dual display for the last week.  No problems cept for
this app but fglrxconfig & fireglcontrol seem to be suitable for now.

[memeyou@Wolley memeyou]$ redhat-config-xfree86
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 450, in __init__
    self.xml.get_widget("secondMonitorLabel").set_text(monitor_list[1].modelname)
TypeError: GtkLabel.set_text() argument 1 must be string, not None
[memeyou@Wolley memeyou]$ rpm -q redhat-config-xfree86
redhat-config-xfree86-0.9.15-1

Comment 7 Red Hat Bugzilla 2006-02-21 18:58:53 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.