Bug 106501 - redhat-config-xfree86-0.9.9-2 crashes w/ some ATI Radeons
redhat-config-xfree86-0.9.9-2 crashes w/ some ATI Radeons
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-config-xfree86 (Show other bugs)
rawhide
i686 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
:
: 106103 107472 108021 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-07 16:49 EDT by Mark Heslep
Modified: 2007-11-30 17:10 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-23 15:29:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for video cards without a driver (1.03 KB, patch)
2003-10-22 22:01 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Mark Heslep 2003-10-07 16:49:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031003
Epiphany/1.0.1

Description of problem:
Latest redhat-config-xfree86 w/ the dual head code tracebacks on a dual head ATI
FireGL X1.  Displays:  NEC LCD 1860NX, Dell P991.
I have X working manually with the stock 'radeon' driver but only single head so
far;  ATI's fglrx drivers do the job for dual head though w/ no Xinerama - a
deal breaker.  Yes the fglrx package is removed and lib-Mesa reinstalled for
these results:


--------------------------------------
$ rpm -q redhat-config-xfree86
redhat-config-xfree86-0.9.9-2

$ /sbin/lspci
...
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R300 NG [FireGL
X1] (rev 80)
01:00.1 Display controller: ATI Technologies Inc Radeon R300 [FireGL X1]
(Secondary) (rev 80)
...

sudo redhat-config-xfree86 --reconfig
Trying with card: ATI FireGL X1
Traceback (most recent call last):
File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
  dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 397, in __init__
  key, value = string.split(card.driver, ":")
ValueError: unpack list of wrong size
----------------------------

Oh, this was run w/ M. Harris's latest XFree86-4.3.0-36

-Mark

Version-Release number of selected component (if applicable):
redhat-config-xfree86-0.9.9-2

How reproducible:
Always

Steps to Reproduce:
1.redhat-config-xfree86  from the commandline w/ X running or not, doesnt matter
2. Or redhat-config-xfree86  --reconfig
3.
    

Actual Results:  Trying with card: ATI FireGL X1
Traceback (most recent call last):
File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
  dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 397, in __init__
  key, value = string.split(card.driver, ":")
ValueError: unpack list of wrong size

Expected Results:  rh-config-xfree86 dialog box should display

Additional info:
Comment 1 Brent Fox 2003-10-08 16:30:10 EDT
Hmm, seems like something is strange with kudzu's probing.  Try this:

1) su to root
2) run 'python'
3) type 'import kudzu'
4) type 'vc = kudzu.probe(kudzu.CLASS_VIDEO, kudzu.BUS_PCI, kudzu.PROBE_ALL)'
5) print vc[0]

Please attach the output to this report.
Comment 2 Mark Heslep 2003-10-08 17:53:03 EDT
]# python
Python 2.2.3 (#1, Jun 10 2003, 16:41:13)
[GCC 3.3 20030604 (Red Hat Linux 3.3-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import kudzu
>>> vc = kudzu.probe(kudzu.CLASS_VIDEO, kudzu.BUS_PCI, kudzu.PROBE_ALL)
>>> print vc[0]
Desc:           ATI|Radeon R300 NG [FireGL X1]
Driver:         Card:ATI FireGL X1
Device:         None
Comment 3 Mark Heslep 2003-10-10 18:06:44 EDT
Tried again w/ latest updates from rawhide:

$ rpm -q kudzu initscripts
kudzu-1.1.32-1
initscripts-7.36-2

Idenitical results, though there seems to be much of a time lag:

$ redhat-config-xfree86 --reconfig
Trying with card: ATI FireGL X1
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 397, in __init__
    key, value = string.split(card.driver, ":")
ValueError: unpack list of wrong size
Comment 4 Markku Kolkka 2003-10-14 11:28:34 EDT
I'm getting a similar crash of redhat-config-xfree86 on a fresh install of
Fedora Core test3. My video card is Sapphire Radeon 9000. 
Comment 5 Brent Fox 2003-10-14 15:06:44 EDT
Hmm, I can't explain what's going on since kudzu seems to be probing your card
just fine.  

Redo the Python commands like before but this time call 'print vc' instead of
'print vc[0]'.  This will show the entire list of videocards that kudzu has
probed.  Maybe it's mis-detecting some other card as a video card...
Comment 6 Dan Williams 2003-10-14 15:37:46 EDT
Python 2.2.3 (#1, Jun 10 2003, 16:41:13)
[GCC 3.3 20030604 (Red Hat Linux 3.3-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import kudzu
>>> vc = kudzu.probe(kudzu.CLASS_VIDEO,kudzu.BUS_PCI,kudzu.PROBE_ALL)
>>> print vc
[Desc:           ATI|Radeon R300 NG [FireGL X1]
Driver:         Card:ATI FireGL X1
Device:         None
, Desc:           ATI|Radeon R300 [FireGL X1] (Secondary)
Driver:         unknown
Device:         None
]
>>>
Comment 7 Mark Heslep 2003-10-14 19:14:59 EDT
$ python
Python 2.2.3 (#1, Jun 10 2003, 16:41:13)
[GCC 3.3 20030604 (Red Hat Linux 3.3-5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
Identical results here with Fedora 0.95 

>>> import kudzu
>>> vc = kudzu.probe(kudzu.CLASS_VIDEO, kudzu.BUS_PCI, kudzu.PROBE_ALL)
>>> print vc
[Desc:           ATI|Radeon R300 NG [FireGL X1]
Driver:         Card:ATI FireGL X1
Device:         None
, Desc:           ATI|Radeon R300 [FireGL X1] (Secondary)
Driver:         unknown
Device:         None
]
Comment 8 Mark Heslep 2003-10-14 19:23:09 EDT
Also, the monitor probe comes back w/ nil:

>>> vc = kudzu.probe(kudzu.CLASS_MONITOR, kudzu.BUS_PCI,kudzu.PROBE_ALL)
>>> print vc
[]
>>>

As does /usr/sbin/ddcprobe directly:

$ /usr/sbin/ddcprobe
 
Monitor DDC probe results
Monitor DDC Probe failed.
Comment 9 Mike Chambers 2003-10-15 09:29:20 EDT
redhat-config-xfree86 failes to start for me as well, on a Radeon 9000 Pro with
a KDS monitor attached (this is listed though in the hwdata file).

[mike@bart mike]$ redhat-config-xfree86
* ddcprobe returned bogus values:
ID:   PTS03e5
Name: None
HorizSync: 30-98
VertSync:  50-160
 
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 398, in __init__
    key, value = string.split(card.driver, ":")
ValueError: unpack list of wrong size
Comment 10 Mike Chambers 2003-10-15 09:30:41 EDT
Couple other comments..

Kudzu is turned off to start on boot currently...

kudzu-1.1.33-1
initscripts-7.37-1
XFree86-4.3.0-39
redhat-config-xfree86-0.9.10-1
Comment 11 Mike Chambers 2003-10-15 09:33:14 EDT
Oh, and here is the python info you wanted as you had someone else do in earlier
comments...

Desc:           ATI|Radeon R250 If [Radeon 9000]
Driver:         Card:ATI Radeon 9000
Device:         fb0
Comment 12 Mike Chambers 2003-10-17 04:31:15 EDT
Bug still exists in version redhat-config-xfree86-0.9.12-1
Comment 13 Elton Woo 2003-10-17 22:49:18 EDT
redhat-config-xfree86 was working until today (17 Oct.) when I updated packages
via up2date (yum - rawhide). I recomplied the nVidia drivers, to boot 
the new kernel, with the usual export CC=gcc32. Running the Display Settings 
from the menu, the dialog window just sits there. 

When invoked from a console, I get the following:

 root]# redhat-config-xfree86
* ddcprobe returned bogus values:
ID:   None
Name: None
HorizSync: None
VertSync:  None
 
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 250, in ok
    self.xconfig.monitor.remove(1)
IndexError: index out-of-bounds

current versions:
XFree86-4.3.0-40
kernel-2.4.22-1.2096.nptl
redhat-config-xfree86-0.9.13-1
Comment 14 Mike A. Harris 2003-10-18 01:57:21 EDT
Elton - your last comment is unrelated to the original report of a problem
with dualhead configuration on ATI hardware.  You're using Nvidia hardware
with proprietary drivers.  While it does appear that you're experiencing
a legitimate bug in the tool, it is an unrelated bug in my opinion.

Please file a brand new bug report for new bugs instead of adding new bugs
to existing defect reports.  Otherwise, when the original issue is fixed
in a given bug report and it gets closed, any other issues reported by other
people which aren't related to the original report get permanently lost.

Thanks in advance.
Comment 15 Elton Woo 2003-10-18 02:04:35 EDT
Oops... Mike ... will do. Someone on the fedora list indicated this was *the*
bug report, but I am now filing a separate bug report against
redhat-config-xfree86-0.9.13-1
Comment 16 Gireesh K. Bhat 2003-10-18 23:52:03 EDT
I am having exactly the same problem as Mike Harris describes above.
My hardware is a DELL Dimension L667r with an Intel i810 4MB onboard video card
and I have another SiS 300 PCI video card with 32MB.
Although RH has never recognised the PCI card during install(even with Onboard
Video DISABLED in the BIOS) I was able to install RH with the Onboard card, run
redhat-config-xfree86 and change the display card to the PCI one.
Now however, redhat-config-xfree86-0.9.13-1 when run gives me the same error as
Mike describes. I have to manually edit the XF86Config file to get the SiS card
to be used.
Does my system qualify as dual-head? Is this the right bug# to be adding my
comments to?
Ohh and by the way I am using Fedora Test3 version but even Test2 on this
machine had the same problem just before test3 was released.
Comment 17 Mike Chambers 2003-10-19 00:22:21 EDT
This bug sounds more and more like a "in general" bug, not so much about the
hardware itself?
Comment 18 Warren Togami 2003-10-22 03:02:58 EDT
I too am hitting this "unpack list of wrong size" error with my Radeon 9200
128MB on my Athlon64, running 32bit Fedora Core 0.95.  I am however able to
modify XF86Config manually, which seems to work fine with full DRI.
Comment 19 Markku Kolkka 2003-10-22 06:06:26 EDT
redhat-config-xfree86-0.9.13-1 still has the same problem. 
 
>>> vc = kudzu.probe(kudzu.CLASS_VIDEO, kudzu.BUS_PCI, kudzu.PROBE_ALL) 
>>> print vc 
[Desc:           ATI|Radeon R250 If [Radeon 9000] 
Driver:         Card:ATI Radeon 9000 
Device:         None 
, Desc:           ATI|Radeon R250 [Radeon 9000] (Secondary) 
Driver:         unknown 
Device:         None 
] 
 
Comment 20 Brent Fox 2003-10-22 14:38:20 EDT
*** Bug 107472 has been marked as a duplicate of this bug. ***
Comment 21 Bill Nottingham 2003-10-22 22:01:18 EDT
Created attachment 95411 [details]
patch for video cards without a driver

This patch should fix the string.split() traceback; it was hiccuping on cards
that didn't have a driver defined.
Comment 22 Elton Woo 2003-10-22 22:31:58 EDT
pardon my ignorance, but how do I (newbieized please...) apply the patch. Thanks.
Comment 23 Warren Togami 2003-10-22 23:20:28 EDT
I tried the patch with my Radeon 9200 128MB.  r-c-x is able to run and configure
settings.  When I click "OK", it fails to quit the program.  The console says:

Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 250, in ok
    self.xconfig.monitor.remove(1)
IndexError: index out-of-bounds

Is this a different bug?
Comment 24 Douglas Furlong 2003-10-23 12:15:58 EDT
lspci

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV280 [Radeon
9200] (rev 01)
01:00.1 Display controller: ATI Technologies Inc: Unknown device 5941 (rev 01)

-----------------------------------------

[root@wibbit redhat-config-xfree86]# python
Python 2.2.3 (#1, Oct 15 2003, 23:33:35) 
[GCC 3.3.1 20030930 (Red Hat Linux 3.3.1-6)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import kudzu
>>> vc = kudzu.probe(kudzu.CLASS_VIDEO, kudzu.BUS_PCI, kudzu.PROBE_ALL)
>>> print vc[0]
Desc:           ATI|Radeon RV280 [Radeon 9200]
Driver:         Card:ATI Radeon 9200
Device:         fb0

>>> 

------------------------------------------

[root@wibbit redhat-config-xfree86]# python
Python 2.2.3 (#1, Oct 15 2003, 23:33:35) 
[GCC 3.3.1 20030930 (Red Hat Linux 3.3.1-6)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import kudzu
>>> vc = kudzu.probe(kudzu.CLASS_VIDEO, kudzu.BUS_PCI, kudzu.PROBE_ALL)
>>> print vc
[Desc:           ATI|Radeon RV280 [Radeon 9200]
Driver:         Card:ATI Radeon 9200
Device:         fb0
, Desc:           ATI|unknown device 1002:5941
Driver:         unknown
Device:         fb0
]
>>>

-------------------------------------------

[root@wibbit redhat-config-xfree86]# python
Python 2.2.3 (#1, Oct 15 2003, 23:33:35) 
[GCC 3.3.1 20030930 (Red Hat Linux 3.3.1-6)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import kudzu
>>> vc = kudzu.probe(kudzu.CLASS_MONITOR, kudzu.BUS_PCI,kudzu.PROBE_ALL)
>>> print vc
[]
>>> 

-------------------------------------------

[root@wibbit redhat-config-xfree86]# /usr/sbin/ddcprobe

Videocard DDC probe results
Description:  ATI Technologies Inc. V280
Memory (MB):  64

Monitor DDC probe results
ID: AOCa790
Name: AOC A790
Horizontal Sync (kHZ): 30-95
Vertical Sync (HZ)  : 50-160
Width (mm): 320
Height(mm): 240

--------------------------------------------

These are the outputs you have asked for through out the history of this bug.

After applying the patch, i am able to get up the configuation settings.

However, when going to the Dual head section, ticking "Use dual head", for the
"second video card:" when selecting the drop down list it appears to be blank
(other then a really little square that seems to be a selection outline if that
makes sense?).

When clicking OK, I get the following at the prompt.

[root@wibbit mnt]# redhat-config-xfree86 
in hydrate_second
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 250, in ok
    self.xconfig.monitor.remove(1)
IndexError: index out-of-bounds

I hope this information is of use, and appologise in advance if I have
duplicated unrequired info.

Doug
Comment 25 Douglas Furlong 2003-10-23 12:19:16 EDT
For Elton Woo (and any others reading this).

To apply the patch down load it (there is a link to it at the bottom of the
page), then move to the directory with xConfigDialog.py in it.

They type cat patchfile | patch.

So for me I do

cd /usr/share/redhat-config-xfree86
cat /tmp/r-c-x.patch | patch

Please note, that this has not fixed all of the problems, there is now an error
on clicking OK.

Hope this helps.

Doug
Comment 26 Brent Fox 2003-10-23 15:06:47 EDT
For those that are seeing the following traceback:

Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 250, in ok
    self.xconfig.monitor.remove(1)
IndexError: index out-of-bounds

this is a different bug than what was originally reported.  Please refer to bug
#107790.
Comment 27 Brent Fox 2003-10-23 15:29:57 EDT
Should be fixed in redhat-config-xfree86-0.9.15-1.  Everybody please test with
it from ftp://people.redhat.com/bfox/redhat-config-xfree86-0.9.15-1.noarch.rpm
and see if it works for you.  It should appear in Rawhide as soon as Rawhide is
up and running again.  Please reopen this report if this update doesn't fix the
problem.


I had to modify notting's patch just a bit.  

The line:
if card.driver[0:4] == "Card:":

should be:

if card.driver[0:5] == "Card:":
Comment 28 Warren Togami 2003-10-23 18:25:58 EDT
*** Bug 106103 has been marked as a duplicate of this bug. ***
Comment 29 Thomas Gordon 2003-10-31 05:12:06 EST
Still not fixed.  Using R300.

[memeyou@Wolley memeyou]$ redhat-config-xfree86
Traceback (most recent call last):
  File "/usr/share/redhat-config-xfree86/xconf.py", line 406, in ?
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, vc)
  File "/usr/share/redhat-config-xfree86/xConfigDialog.py", line 450, in __init__
    self.xml.get_widget("secondMonitorLabel").set_text(monitor_list[1].modelname)
TypeError: GtkLabel.set_text() argument 1 must be string, not None


[memeyou@Wolley memeyou]$ rpm -q redhat-config-xfree86
redhat-config-xfree86-0.9.15-1


[memeyou@Wolley memeyou]$ /sbin/lspci
...
03:00.0 VGA compatible controller: ATI Technologies Inc Radeon R300 AD [Radeon
9500 Pro]
03:00.1 Display controller: ATI Technologies Inc Radeon R300 Secondary (DVI) output
...
Comment 30 Mike Chambers 2003-11-13 08:39:56 EST
Seems to work with package included with FC1.

redhat-config-xfree86-0.9.15-1
Comment 31 Brent Fox 2004-02-19 22:13:47 EST
*** Bug 108021 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.