Bug 106132 - nautilus-media should depend on gstreamer 0.6.1 and gstreamer-plugins 0.6.1
nautilus-media should depend on gstreamer 0.6.1 and gstreamer-plugins 0.6.1
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: nautilus-media (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Colin Walters
David Lawrence
: Triaged
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-02 20:16 EDT by Max Kanat-Alexander
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version: 0.8.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 15:05:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of rpm -qa (27.48 KB, text/plain)
2003-10-02 20:24 EDT, Max Kanat-Alexander
no flags Details
Outuput of rpm -qa | sort (27.48 KB, text/plain)
2003-10-02 20:28 EDT, Max Kanat-Alexander
no flags Details

  None (edit)
Description Max Kanat-Alexander 2003-10-02 20:16:55 EDT
Briefly: The SRPM should "BuildRequires: gstreamer-devel >= 0.6.1," instead of
0.6.0.

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030917
Firebird/0.6.1+

Description of problem:
Building the source RPM of nautilus-media (version specified above) gives me
this message:

No package 'gstreamer-0.7' found
Requested 'gstreamer-0.6 >= 0.6.1' but version of GStreamer is 0.6.0
configure: error: you need gstreamer development packages installed !
error: Bad exit status from /var/tmp/rpm-tmp.94856 (%build)
    Bad exit status from /var/tmp/rpm-tmp.94856 (%build)

Basically, it fails during configure, instead of the dependency being set
explicitly in the RPM. It should probably just be "BuildRequires:
gstreamer-devel >= 0.6.1" instead of "gstreamer-devel >= 0.6.0".

Version-Release number of selected component (if applicable):
nautilus-media-0.3.1-1

How reproducible:
Always

Steps to Reproduce:
1. Have gstreamer-0.6.0 installed
2. Attempt to build nautilus-media from SRPM currently in rawhide.
    
Actual Results:  nautilus-media fails to build in the middle of configure

Expected Results:  nautilus-media fails to build at the invocation of rpmbuild.
Comment 1 Max Kanat-Alexander 2003-10-02 20:20:22 EDT
Graaaah. Never mind. Something else is up. The package also fails to build with
the current gstreamer in rawhide. I've built and installed gstreamer-0.6.3 and
its packages, and now I get:

No package 'gstreamer-0.7' found
Requested 'gstreamer-libs-0.6 >= 0.6.1' but version of GStreamer Media-Specific
Libraries is 0.6.0
configure: error: you need gstreamer development packages installed !

-M
Comment 2 Max Kanat-Alexander 2003-10-02 20:24:43 EDT
Created attachment 94904 [details]
Output of rpm -qa

Here's the output of rpm -qa, so you can see the current state of installations
on my machine.

-M
Comment 3 Max Kanat-Alexander 2003-10-02 20:28:08 EDT
Created attachment 94905 [details]
Outuput of rpm -qa | sort

Sorry for the spam. This one should be actually useful. -M
Comment 4 Max Kanat-Alexander 2003-10-03 01:40:52 EDT
Changed the summary. That's the solution.

It also depends on gstreamer-plugins-0.6.1, not the gstreamer/gstreamer-plugins
0.6.0 that comes which RH9.

-M
Comment 5 Alexander Larsson 2003-10-06 12:45:36 EDT
Ah. That makes sense. 

Note You need to log in before you can comment on or make changes to this bug.