Bug 1061387 - Remove Cherokee from Fedora
Remove Cherokee from Fedora
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cherokee (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Pavel Lisý
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-04 13:11 EST by Richard Fontana
Modified: 2014-08-25 20:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 17:41:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Fontana 2014-02-04 13:11:53 EST
A person who I believe is the maintainer, or one of the maintainers, of the Cherokee project upstream has made threatening remarks towards me
https://bugzilla.redhat.com/show_bug.cgi?id=1060984#c3
based, he says, on my comment https://bugzilla.redhat.com/show_bug.cgi?id=681339#c56.

It is of note that in the earlier bug I was acting as a Fedora user, expressing my desire simply to see Fedora determine whether Cherokee violates Fedora's stated standards for acceptable content. In the the latter bug I was acting as a representative of Red Hat. 

I hope it is clear why we cannot tolerate a situation in which upstream projects make threats against Fedora users and representatives of sponsors of the Fedora project. 

I am requesting on behalf of Red Hat that Cherokee be pulled from the Fedora distribution. 

Should this request not be acted upon by package maintainer Pavel Lisy in due course, I shall take the extraordinary step of asking to be made Fedora package maintainer of Cherokee myself on the principle that Pavel Lisy has constructively shown himself to be nonresponsive to the Cherokee logo issue. The likely outcome at that point, should that occur, is also that Cherokee will be pulled from the Fedora distribution.
Comment 1 Richard Fontana 2014-02-04 13:12:28 EST
cc'ing Fedora Legal
Comment 2 Tom "spot" Callaway 2014-02-04 16:29:53 EST
Richard, I think you're over reacting to someone else's stupidity, but I suppose that is your right (and that is just my personal opinion, not that of Red Hat).

Nevertheless, this is not the appropriate forum for that sort of request. If you really wish for Cherokee to be stripped from the current maintainer, that would need to go to the Fedora Board. Please open a ticket there:

https://fedorahosted.org/board/
Comment 3 Richard Fontana 2014-02-05 00:54:59 EST
Reopening. Just to clarify, the request was that Cherokee be pulled out of Fedora for the reasons stated. If that itself is a Fedora Board decision, then this can be re-closed.
Comment 4 Tom "spot" Callaway 2014-02-05 17:41:23 EST
We do not track package removals due to conflicts between community members and the upstream as bugzilla bugs. Re-closing.
Comment 5 Richard Fontana 2014-02-05 17:44:52 EST
That isn't really how I'd characterize the issue, but I suppose I may be anticipating a policy that does not currently exist. I am now no longer sure why we track legal issues as bugzilla bugs.
Comment 6 Tom "spot" Callaway 2014-02-05 17:47:23 EST
This isn't really a legal issue, it is a code of conduct issue or a broader project decision, and as such, it needs to go before the board for resolution.
Comment 7 Richard Fontana 2014-02-05 18:20:47 EST
Well, okay. I will plan on proposing to the Fedora Board that it adopt a policy that threats by upstream project leads against Fedora users ought to be treated similarly to legal issues. This case admittedly is unusual, but I can imagine other cases where I would be hard-pressed to understand why threats by an upstream project lead against a Fedora user is not a variety of legal issue.
Comment 8 Tom "spot" Callaway 2014-02-06 11:58:50 EST
If the Board determines that Fedora Legal is responsible for these sorts of cases, then it will act on them, but for now, I'd prefer the Board handle them.

Note You need to log in before you can comment on or make changes to this bug.