Bug 106149 - Cannot save menu item to disk - Error writing ... unsupported operation
Cannot save menu item to disk - Error writing ... unsupported operation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Mark McLoughlin
: Triaged
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-03 06:10 EDT by Jari Aalto
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-08 16:23:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-panel-2.4.2-disable-add-new-menu-item.patch (817 bytes, patch)
2004-03-07 04:20 EST, Bart Martens
no flags Details | Diff

  None (edit)
Description Jari Aalto 2003-10-03 06:10:58 EDT
Description of problem:

It is not possible to add menu items while logged as root:
"Cannot save menu item to disk - Details: Error writing 
file applications:/internet/dillo.desktop: unsupported operation"

dillo is a fast C++ based browser. Suitable for low memory machines.

Version-Release number of selected component (if applicable):

Fedora test 2
[root@conde iso]# rpm -qa | grep gnome
libgnomeui-2.4.0-1
gnome-vfs-1.0.5-15
gnome-icon-theme-1.0.6-1
gnome-media-2.3.7-1
gnome-mime-data-2.3.2-1
libgnomecanvas-2.4.0-1
libgnome-2.4.0-1
gnome-python2-bonobo-2.0.0-1
gnome-python2-2.0.0-1
openssh-askpass-gnome-3.6.1p2-19
gnome-desktop-2.4.0-1
gnome-pilot-2.0.10-2
libgnomeprintui22-2.3.1-2
gnome-vfs2-extras-0.99.10-3.1
libgnomeprintui-1.116.0-5
gnome-audio-1.4.0-6
gnome-vfs-extras-0.2.0-7
gnome-mag-0.10.2-3
gnome-themes-2.3.3-1
switchdesk-gnome-3.9.8-18
gnome-system-monitor-2.3.0-1
gnome-utils-2.4.0-1
gnome-applets-2.3.7-1
gnome-user-docs-2.0.1-3
gnome-session-2.4.0-1
gnome-python2-canvas-2.0.0-1
gnome-vfs2-2.4.0-1
gnome-panel-2.4.0-1
up2date-gnome-3.9.29-2
libgnomeprint22-2.3.1-2
libgnomeprint-1.116.0-7
gnome-terminal-2.4.0.1-1


How reproducible:

Always
Steps to Reproduce:


0. Install pure fedora test 2
1. log in as root
2. Start gnome from bash with:

    # startx $(which gnome-session)

3. Try adding the menu a new item using mouse
   (Hat => Internet => (right click) => entire menu
   => add new item to this menu

    
Actual results:

"Cannot save menu item to disk - Details: Error writing 
file applications:/internet/dillo.desktop: unsupported operation"
Expected results:


Additional info:
[root@conde applications]# id -a
uid=0(root) gid=0(root) groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),
10(wheel)
[root@cond
[root@conde applications]# pwd
/usr/share/applications
[root@conde applications]# ls -la | head
total 171
drwxr-xr-x    2 root     root         3072 Oct  1 14:17 .
drwxr-xr-x  156 root     root         3072 Oct  2 21:59 ..
-rw-r--r--    1 root     root          227 Sep 16 06:16 abiword.desktop
-rw-r--r--    1 root     root          452 Aug 26 20:47 gaim.desktop
Comment 1 Jonathan Blandford 2003-10-09 14:05:29 EDT
The Gnome Panel should probably hide this feature until we get menu editing working.
Comment 2 lupus 2003-11-04 15:45:53 EST
got the same problem with test3
Comment 3 Davis Webster 2003-11-12 02:34:24 EST
the same problem is with core 1.  I herd this is because the format is
saved in an xml format and you have to manually enter it.
Comment 4 Bart Martens 2004-03-07 03:16:11 EST
This problem is also reported upstream.
http://bugzilla.gnome.org/show_bug.cgi?id=124908
Comment 5 Bart Martens 2004-03-07 04:20:25 EST
Created attachment 98354 [details]
gnome-panel-2.4.2-disable-add-new-menu-item.patch

I agree with jrb to temporarily disable the "add new item to menu" option,
until the problem is fixed upstream.
Comment 6 Mark McLoughlin 2004-03-08 16:23:12 EST
Menu editing has been re-enabled in FC2 since gnome-vfs2-2.5.5 or so.

Note You need to log in before you can comment on or make changes to this bug.