Bug 106156 - Hiding panel makes it completely vanish
Hiding panel makes it completely vanish
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
David Lawrence
: Triaged
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-03 08:27 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.4.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 10:51:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2003-10-03 08:27:32 EDT
Description of problem:
Hiding the panel using the hide buttons makes it completely vanish, so that it
can no longer be unhidden.

Version-Release number of selected component (if applicable):
gnome-panel-2.4.0-1

How reproducible:
100%

Steps to Reproduce:
1. Enable hide buttons.
2. Click one.
Comment 1 Alexander Larsson 2003-10-06 11:03:22 EDT
I don't actually get this. Can you describe in more detail how you make this happen?
Comment 2 Tim Waugh 2003-10-23 16:35:00 EDT
I can't really; there's no more to it.  I just did it again!  :-((

This is 100% repeatable here.
Comment 3 Tim Waugh 2003-10-23 16:35:59 EDT
(Is anyone getting email updates on this bug?  Bugzilla says it sent email to
'no one', which doesn't seem terribly helpful..)
Comment 4 Leonard den Ottolander 2004-02-13 14:19:51 EST
I assume this issue is resolved in gnome-panel-2.4.0-3? If so this bug
can be closed.
Comment 5 Tim Waugh 2004-02-13 17:47:50 EST
No, unfortunately not.
Comment 6 Leonard den Ottolander 2004-02-14 13:10:08 EST
Any idea if this was fixed upstream? Do you have autohide enabled? I
am also unable to reproduce this, at least with a second panel I can
not make it vanish.

Since there are many open issues with gnome-panel it might be worth
releasing an update in testing. Either the current version with a
bunch of applied patches (I am working on gathering some), or by
moving to 2.4.2. I'll start a thread on the issue on fedora-devel the
beginning of next week.
Comment 7 Tim Waugh 2004-02-17 07:36:35 EST
Autohide is not enabled.  I haven't tried a newer gnome-panel on this
machine.
Comment 8 Bart Martens 2004-02-19 12:26:34 EST
Tim, I can't reproduce the problem on Fedora Core 1 with
gnome-panel-2.4.0-3. One of the hide buttons always remains visible,
and I can use that button to unhide the panel.

Can you give more details on how you reproduce the problem with this
version of gnome-panel?
Comment 9 Mark McLoughlin 2004-02-23 08:14:06 EST
I'm stumped, haven't heard any reports of this since 2.3.x. You aren't
using something wacky like multi-screen or Xinerama by any chance? :-)

I'll be putting out an FC1 update sometime this week with gnome-panel
2.4.2. I'd appreciate it if you could test it then.

Moving to Fedora Core 1, since this is the version of the panel we
have there.
Comment 10 Tim Waugh 2004-02-23 08:27:13 EST
No, nothing wacky.  I'll let you know what change, if any, the testing
update makes.
Comment 11 Mark McLoughlin 2004-02-23 17:43:30 EST
I've pushed gnome-panel-2.4.2-1. Let me know if it makes any difference.
Comment 12 Tim Waugh 2004-02-24 04:37:33 EST
Yes, that fixes it.  Thanks!
Comment 13 Mark McLoughlin 2004-03-02 10:51:56 EST
Okay, a gnome-panel Fedora Core 1 Update (2.4.2-3) with a fix
for this bug is now available from:

   http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/

Note You need to log in before you can comment on or make changes to this bug.